[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Bug#710297: cups: server-error-internal-error encountered when setting up new printer (Dell 5130cdn color laser)



retitle 710297 cups: server-error-internal-error encountered when setting up new printer (Dell C3760dn color laser)
thanks



On Wed 29 May 2013 at 12:30:40 -0400, Wirawan Purwanto wrote:

Helo Wirawan. Thank you for your report.

> In Debian 7 stable with the provided cups (1.5.3-5) I tried to add a new
> printer with external PPD file. The printer is: Dell C3760DN color laser
> printer, and I used the PPD given by Dell.
> The driver (PPD actually) was obtained from
> 
> http://www.dell.com/support/drivers/us/en/04/DriverDetails/Product/dell-
> c3760dn?driverId=YN48J&osCode=LNUX&fileId=2998271512&languageCode=EN&categoryId=DD
> 
> I converted the RPM to DEB with alien. Installed it, and tried to set up the
> printer using the GTK GUI (system-config-printer command). I then specified the
> PPD location manually in the dialog titled "Choose Driver". But when I clicked
> "Apply" in the "Describe Printer", an error message shows up with this error:
> 
>    CUPS server error
>    There was an error during the CUPS operation: 'server-error-internal-error'.
> 
> I increased the log level to 'debug2' in /etc/cups/cupsd.conf and I found this
> portion surrounding the error message in /var/log/cups/error_log:
> 
> d [29/May/2013:11:59:33 -0400] cupsdAddPrinter("dellcolor")
> d [29/May/2013:11:59:33 -0400] cupsdAddPrinter: Adding dellcolor to Printers
> I [29/May/2013:11:59:33 -0400] Setting dellcolor device-uri to
> "socket://prism.physics.wm.edu:9100" (was "file:///dev/null".)
> d [29/May/2013:11:59:33 -0400] set_printer_defaults: printer-info
> d [29/May/2013:11:59:33 -0400] set_printer_defaults: printer-location
> d [29/May/2013:11:59:33 -0400] set_printer_defaults: device-uri
> d [29/May/2013:11:59:33 -0400] copy_file("/var/spool/cups/00000001", "/etc/cups/interfaces/dellcolor")
> D [29/May/2013:11:59:33 -0400] CUPS-Add-Modify-Printer server-error-internal-error: Unable to copy interface script - No such file or directory

CUPS appears to think it is dealing with a System V interface script, not a PPD.

I do not have access to system-config-printer at present but in the
meantime I downloaded the zip file above, used alien as you did and
extracted Dell_C3760dn_Color_Laser.ppd.gz to my home directory.

First - a couple of quick checks:

   brian@desktop:~$ file Dell_C3760dn_Color_Laser.ppd
   Dell_C3760dn_Color_Laser.ppd: PPD file, version "4.3"

   brian@desktop:~$ cupstestppd Dell_C3760dn_Color_Laser.ppd
   Dell_C3760dn_Color_Laser.ppd: PASS

Using localhost:631 I installed a print queue by providing the PPD to
CUPS. Compressed or uncompressed the install was successful.

I also did

   lpadmin -v socket://191.168.7.200:9105 -p test -P /home/brian/Dell_C3760dn_Color_Laser.ppd.gz

with similar success.


> E [29/May/2013:11:59:33 -0400] Returning IPP server-error-internal-error for
> CUPS-Add-Modify-Printer (ipp://localhost/printers/dellcolor) from localhost
> d [29/May/2013:11:59:33 -0400] cupsdProcessIPPRequest: ippLength(response)=153
> 
> I checked that in my installation (which is debian 7 amd64, xfce desktop,
> installed from LiveCD), there is no subdir /etc/cups/interfaces . I made that
> subdirectory manually, and the printer setup process continues. But in the end
> I saw a blank /etc/cups/interfaces/dellcolor, while I saw no
> /etc/cups/interfaces/dellcolor.ppd . This is strange!
> 
> I am reporting this bug per chance someone can help out and fix this problem.

>From my perspective there is nothing to fix. :)

Regards,

Brian.


Reply to: