[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Re: Performing installer tests on PowerMac with USB sticks

Am 01.05.19 um 12:18 schrieb aggaz:
> After reading your email I was able to see that with a USB stick
> inserted at boot a disk device indeed shows up in the device tree
> (visible by using the command "dev / ls"), but I am still not able to
> list its files by using the command "dir".

Which command are you using?

I've seen similiar issues when using a devalias, e.g. hd:, instead I had
to use ultra1: for my first ATA HDD. That seems odd considering that the
Mac boots fine with the command boot hd:, yet seems unable to list files
on that very same device (alias).

Did you try the full device tree path as well?

Should look like:

> dir /pci@f2000000/mac-io@17/ata-3@20000/disk@0:3,\

Or, for a USB path:

> dir /ht@0,f2000000/pci@4/usb@b/disk@2:2,\

(yours will look different, as those from above are from a Power Mac G5)

> By the way, the USB stick contains a dd'ed debian ISO image and it is
> possible to browse its files on a PowerMac G5 (PowerMac11,2).

That is the same way I did it, I used dd on my Linux machine and
successfully booted the netinst image on my iBook G3 from 1999.

> I think I am using the correct OF path, derived by looking at the device
> tree and by comparison with the working path on the G5.

Are you using an alias like usb0: or ud0: or are you using the full
device tree as the path? (BTW, I would try both...)

> For what is worth, I think that a developer in need to test several CD
> images without burning them should consider investing in a FireWire HD.
> As far as I know booting from FireWire should be much easier, but I
> never tried it.

Which reminds me... I have a FireWire SATA dock that I use with PCs (USB
3.0 or eSATA) and Macs (FW400 and FW800). But I've had issues with this
dock when trying to boot from it. Somehow it doesn't always show up as a
valid boot option. Another similar dock always worked (but I have given
this other dock away, thinking they are the same), so I'm guessing that
it must be some weird time-out issue or such, as all the disks work once
booted up.


Linux User #330250

Reply to: