[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Re: Unable to log in to iMac G4, graphical login workaround?

Okay, again, thank you everyone for the information. Looks like this is definitely the video driver.

I am wondering, would I have better results if I tried installing Wheezy or Squeeze instead of Jessie?

On Thu, Oct 1, 2015 at 1:37 AM, Herminio Hernandez Jr. <herminio.hernandezjr@gmail.com> wrote:
Another great resource is here 
Sent from my iPhone

On Sep 30, 2015, at 11:23 PM, Roger Harkavy <rogerharkavy@gmail.com> wrote:

Ah, this information is helping! The following options allow me to get to where what should be the login screen appears, but it is black with a purple cursor:




From there I can press Ctrl-Alt-F1 and get to a command prompt.

I also tried these commands but neither of them change anything:




Maybe I can try them all together? I don't know. I feel like I am getting closer, though. It is a problem with the Nouveau driver.

On Wed, Sep 30, 2015 at 11:26 PM, Herminio Hernandez, Jr. <herminio.hernandezjr@gmail.com> wrote:
It is deal with G5 but I think the Nvidia issue may apply to you.

On Wed, Sep 30, 2015 at 10:18 PM, <http@shaw.ca> wrote:
Dear Roger,

What I would try is appending "single" to the "Linux" option at the second stage yaboot prompt.


On 30/09/15 07:33 PM, Roger Harkavy wrote:
I originally posted this on the Debian user forums but I was directed to
this mailing list. Hopefully I can give you enough information for some
guidance on troubleshooting this.

I have an iMac G4 "desk lamp," 512k of RAM, 200 GB HD, I believe the
processor is a 7450. I downloaded the Debian Jessie netboot powerpc
"mini.iso" image from here and burned it to a CD:


Installation seemed to go smoothly, no errors, and I selected MATE as the
desktop choice during install. The only other option I selected was the
"additional desktop software" (sorry, do not remember the exact text).

However, after installation, when it boots, one of the last messages you
see is:

[FAILED] Failed to start Load Kernel Modules.

Last line is something along the lines of:

fb: switching to nouveaufb from OFfb NVDA,NVMac

And then the text starts dissolving, and the entire screen cycles through
different colors. I presume it is sitting at the graphical login prompt but
it's not displaying correctly.

Based on some Google searches, it seems like I should be able to resolve
this by editing /etc/modules using nano from a command prompt but I can't
get to that point. After the machine starts cycling through the colors, I
press ctrl-alt-F1 through ctrl-alt-F12. If there is a command prompt being
offered, I can't see it.

I also tried different yaboot options I found in searches that were
supposed to avoid using the video driver. Unfortunately these didn't work
either, but maybe I'm not choosing the right ones.

How do I get the machine to boot straight to a regular text login instead
of the X-based one?

Also, this machine worked fine running Mac OS X this morning (partition was
deleted during the install process), so I don't think it's the hardware.

Please let me know what I can do. Thank you in advance for any help you can

Reply to: