[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Unable to log in to iMac G4, graphical login workaround?

I originally posted this on the Debian user forums but I was directed to this mailing list. Hopefully I can give you enough information for some guidance on troubleshooting this.

I have an iMac G4 "desk lamp," 512k of RAM, 200 GB HD, I believe the processor is a 7450. I downloaded the Debian Jessie netboot powerpc "mini.iso" image from here and burned it to a CD:


Installation seemed to go smoothly, no errors, and I selected MATE as the desktop choice during install. The only other option I selected was the "additional desktop software" (sorry, do not remember the exact text).

However, after installation, when it boots, one of the last messages you see is:

[FAILED] Failed to start Load Kernel Modules.

Last line is something along the lines of:

fb: switching to nouveaufb from OFfb NVDA,NVMac

And then the text starts dissolving, and the entire screen cycles through different colors. I presume it is sitting at the graphical login prompt but it's not displaying correctly.

Based on some Google searches, it seems like I should be able to resolve this by editing /etc/modules using nano from a command prompt but I can't get to that point. After the machine starts cycling through the colors, I press ctrl-alt-F1 through ctrl-alt-F12. If there is a command prompt being offered, I can't see it.

I also tried different yaboot options I found in searches that were supposed to avoid using the video driver. Unfortunately these didn't work either, but maybe I'm not choosing the right ones.

How do I get the machine to boot straight to a regular text login instead of the X-based one?

Also, this machine worked fine running Mac OS X this morning (partition was deleted during the install process), so I don't think it's the hardware.

Please let me know what I can do. Thank you in advance for any help you can provide.

Reply to: