[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Re: Bug#678066: Proposal to simplify PowerPC CD/DVD boot options

On Aug 29, 2012, at 11:04 PM, Milan Kupcevic wrote:

On 08/29/2012 07:58 PM, Rick Thomas wrote:

On Aug 29, 2012, at 4:25 PM, Rick Thomas wrote:

I just tried booting a PowerMac G4 with the Wheezy installer image
"built on 20120826-03:23" (details of where I downloaded it from, etc
available on request).

The G4 is a 32-bit machine, but it seems to be offering me the choices
for a 64 bit machine.

Before the "boot:" prompt it said (among other things)
  install     64-bit processor (G5 or POWER3/4/5/6/7)
  install32   32-bit processor (G4 or earlier)

and when I entered <tab> at the "boot:" prompt I saw the list of options
  install   expert      rescue
  auto      install32   expert32
  rescue32  auto32

At this point you can still type: install32

If I just hit <ret> at the "boot:" prompt it looks like it's trying to
boot the 64-bit kernel, which (of course) fails on the G4.

The only unusual thing about this is that I'm booting from a USB stick using Open Firmware, rather than from a physical CD-ROM. Should that
make any difference?

When you load yaboot binary directly from Open Firmware you are skipping
blessed stage one boot loader script. That is making the difference.

I just tried booting that installer from a physical CD-ROM on the G4. I
got the expected (32-bit) messages.

So, I guess booting from a CD sets something in the OF environment that
isn't being set when booting from a USB stick?

By default, PowerPC Macs boot from a CD/DVD drive by loading an Apple
specific blessed file located in an Apple_HFS partition. The blessed
file is a stage one boot loader. It is a file containing Open Firmware
commands that are figuring out whether they run on 32-bit or 64-bit
machine, followed by a boot command that loads yaboot binary while
passing appropriate arguments to it.

If yaboot binary gets loaded without arguments it will offer both 64- bit
and 32-bit options, but default to 64-bit.

Is there a fix for this, or is it an un-common enough use-case to just
need to be documented as a limitation.

The on-screen instructions are correct. Thus, the manual could just say
something like this: "When the machine boots, follow the on screen


Thanks for the explanation. It helps me understand what's going on here.

What you say is, of course, technically correct. The problem I'm having is that this is an about-face change from previous practice. Previously, 32-bit was the default, and 64-bit was the specific option. Now it's the reverse.

Has there been a sea-change? Are G5 machines now more common than G4s? If so it could justify a reversal of long established behavior. But, while I have no statistics to quote, I doubt it based on the comments I've read in the lists. Actually, I think the large majority of old Apple machines people are trying to use with Debian are G4s.

Regardless, I'm trying to write a comprehensive set of notes on booting Apple PowerMacs from USB drives, and it would be nice to have this part fully documented.

Is there something I can tell people to do at the OF prompt that will load and run the stage-one boot loader?

If it's not possible to run the stage-one boot loader, is there something I can tell them to do that will pass the appropriate arguments to yaboot to make it do the "right thing" for their machine?



PS: I think the work you're doing on this is a big step in the right direction. I'm a fan of the PowerPC architecture, and I'm just trying to help make the experience of Debian on old Macs as good as we know it can be!

Reply to: