[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Re: Bug#678066: Proposal to simplify PowerPC CD/DVD boot options

On Aug 29, 2012, at 4:25 PM, Rick Thomas wrote:

I just tried booting a PowerMac G4 with the Wheezy installer image "built on 20120826-03:23" (details of where I downloaded it from, etc available on request).

The G4 is a 32-bit machine, but it seems to be offering me the choices for a 64 bit machine.

Before the "boot:" prompt it said (among other things)
   install     64-bit processor (G5 or POWER3/4/5/6/7)
   install32   32-bit processor (G4 or earlier)

and when I entered <tab> at the "boot:" prompt I saw the list of options
   install   expert      rescue
   auto      install32   expert32
   rescue32  auto32

If I just hit <ret> at the "boot:" prompt it looks like it's trying to boot the 64-bit kernel, which (of course) fails on the G4.

The only unusual thing about this is that I'm booting from a USB stick using Open Firmware, rather than from a physical CD-ROM. Should that make any difference?

I just tried booting that installer from a physical CD-ROM on the G4. I got the expected (32-bit) messages.

So, I guess booting from a CD sets something in the OF environment that isn't being set when booting from a USB stick?

Is there a fix for this, or is it an un-common enough use-case to just need to be documented as a limitation.



Reply to: