[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Re: sound problem ibook g4

* m laks [110427 18:03 -0700]:

> Hi I have been using debian squeeze and now sid  on a ibookg g4
> 1.2Ghz which  i believe is a  late 2004 machine - 30G harddrive.
> Some time ago  (way before squeeze) sound  stopped working at all. 
> instead I get a scratchy terrible sound that sounds like someone
> blowing air under their tongue while scratching their fingernails
> on glass, whenever I try to listen to a ogg or mp3 lecture or
> music. 
> When I downloaded a  ubuntu live disk 10.04 sound works fine. So
> it is not a hardware problem.

A good way of debugging would be to list the snd modules Ubuntu
distro is using. I guess snd-aoa-codec-tas should be correct for
your machine. Could you please send the output of

$ lsmod | grep snd

from your Ubuntu distro?

> I had the problem for some before squeeze time and was running
> squeeze with this problem too. I tried some random things i
> googled - such as putting snd-powermac in the /etc/modules
> directory as well as putting 

Don't put any snd module in /etc/modules and let udev do the job.

> the  following modules to be blacklisted:
> snd-aoa
> snd-aoa-codec-tas
> snd-aoa-fabric-layout
> snd-aoa-i2sbus
> snd-aoa-soundbus

Don't do that.

> - 
> this had no effect. still the same bad sound.
> I upgraded to the latest sid kernel 2.6.38-2 from the squeeze
> kernel and no help. I also tried installing the latest alsa-driver
> from the alsa web site and this did not help?
> Is there anything that I can do to get this very portable nice
> laptop sound working? It worked fine for the longest time...

Do what I've mentioned above, reboot and post the following outputs
as user:

$ lsmod | grep snd
$ cat /proc/asound/cards
$ cat /proc/asound/version
$ dpkg -l | egrep "(alsa-|asound)"
$ aplay -lL
$ groups


  It's a good thing we don't get all 
  the government we pay for.

Reply to: