[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Re: Unofficial Squeeze NetInst CDs: call for testers



Hello,

On Wed, Dec 15, 2010 at 05:34:52PM -0500, Milan Kupcevic wrote:
> Ok. I just tried to install [1] on Power IntelliStation 275. It
> installs, reboots, and works fine.
> 
> At one point yaboot-installer code calls
> 
>  /usr/lib/partconf/find-partitions --flag prep
> 
> which is supposed to return prep boot partition, but in your case it
> looks like it returns nothing.

not exactly nothing, but better still a clue ;-)

  ~ # /usr/lib/partconf/find-partitions --flag prep
  Warning: The driver descriptor says the physical block size is 512 bytes, but
  Linux says it is 2048 bytes.  A bug has been detected in GNU Parted.  Refer
  to the web site of parted http://www.gnu.org/software/parted/parted.html for
  more information of what could be useful for bug submitting!  Please email a
  bug report to bug-parted@gnu.org containing at least the version (2.3) and
  the following message:  Assertion (disk != NULL) at
  ../../libparted/disk.c:1548 in function ped_disk_next_partition() failed.
  Aborted
  ~ # echo $?
  134

For testing purposes i copied over the find-partitions and its libs
from the squeeze install to my already running lenny on PPC. There
it seems to work:

  /tmp# LD_LIBRARY_PATH=/tmp/ /tmp/find-partitions --flag prep
  /dev/sda1               7.8 MiB
  /dev/sdb1               7.8 MiB
  /dev/mapper/mpath0p1            7.8 MiB
  /tmp# echo $?
  0

(Mind though that all the devices are referring to the same disk, since
it's mapped through dual VIOS.)

Any idea what went wrong with the squeeze LPAR? Is this maybe an issue
with the ibmvscsic kernel module?

Thanks & best regards,

    Frank


Reply to: