[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Re: Unofficial Squeeze NetInst CDs: call for testers

On 12/15/2010 02:31 AM, Frank Fegert wrote:
> Hello,
> On Tue, Dec 14, 2010 at 11:43:03PM +0100, Gaudenz Steinlin wrote:
>> Excerpts from Frank Fegert's message of Die Dez 14 19:34:12 +0100 2010:
>>> i tried the unofficial-debian-squeeze-powerpc-netinst-1-yaboot-1.3.16.iso
>>> on a p550 Power6+ LPAR, Microcode 01EL350_085_038, dual VIOS. The
>>> install fails at "Install yaboot on a hard disk" with:
>>>   [!!] Install yaboot on a hard disk
>>>   No bootstrap partition found
>>>   No hard disks were found which have an "Apple_Bootstrap" partition.
>>>   You must create an 819200-byte partition with type "Apple_Bootstrap".

This error message comes from yaboot-installer when it is not able to
find ANY bootable partition, not just when there is no "Apple_Bootstrap"
partition. This is a generic error message pulled from
yaboot-installer.templates, which has to be changed because it gives
wrong advice to non Mac users.

>>> Exiting to a shell shows the following partition layout:
>>>   ~ # /target/sbin/sfdisk -l
>>>   Disk /dev/sda: 16384 cylinders, 64 heads, 32 sectors/track
>>>   Units = cylinders of 1048576 bytes, blocks of 1024 bytes, counting from 0
>>>      Device Boot Start     End   #cyls    #blocks   Id  System
>>>   /dev/sda1          1      10      10      10240   41  PPC PReP Boot
>>>   /dev/sda2         11     964     954     976896   83  Linux
>>>   /dev/sda3        965   16382   15418   15788032   8e  Linux LVM
>>>   /dev/sda4          0       -       0          0    0  Empty

Are these partitions created manually? PPC PReP boot partition should be
between 4-8 MB, not bigger than 10MB. It also has to be a primary
partition and marked active/bootable. This one is not marked bootable.

If you want to use LVM you will have to put /boot on second primary
partition (sda2) and copy yaboot.conf from /etc/yaboot.conf to
/boot/etc/yaboot.conf at the end of installation procedure (right before
installer reboots the machine). Sorry, yaboot-installer development was
stalled for last 5 years.

>> Do you know if this error is a regression regarding the lenny
>> installer or the current official beta2 installer? If so we have to
>> investigate this and fix the bug before the packages enter testing.
>> But I suspect this nerver worked. See also Debian bugs #332227, #352914
>> and #350372. I guess this really needs someone with the right hardware
>> to dig in and solve the bugs or write the missing code for the
>> installer.

Bug 352914 was influenced by the same misleading error message. All
three bug reports became one big confused discussion.

> the ISOs i used for previous installs were debian-500-powerpc-netinst.iso
> and debian-504-powerpc-netinst.iso, both worked as far as the install is
> concerned. There were some yaboot issues with getting the successfully in-
> stalled system to boot (see my previous postings to the list).

Could you please do clean install on one disk with no lvm, no raid, no
manual partitioning. Just choose "Guided - use entire disk," and then
"All files in one partition."

If you hit an error screen, download all install logs, pack them and
send with your report. When you test official install CD, submit
official installation-report or bug report. We can discuss unofficial
install CD issues in this mailing list.

Thank you for the extra info you collected from the installer. The nvram
info you sent is useful, boot-device was set to network boot. I'm
collecting content of boot-device and diag-device variables from nvram
on various configurations. Currently I need the most those that are set
to boot Linux or AIX installed in any LPAR, especially if they boot from
a virtual drive provided by VIOS. Can you get output of /sbin/nvsetenv
from already running Linux installations that you have around?



Attachment: signature.asc
Description: OpenPGP digital signature

Reply to: