[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Re: xorg issues with lenny and PowerBook G4 [Revisited]

On Mon, 25 Aug 2008 16:38:00 -0300
Sebastien G <sebas-listes@koumbit.org> wrote:

> Amit a écrit :
> > Hey there,
> > 
> > I was unsuccessful in installing Lenny a few months ago so I reverted
> > back to Debian Etch. A few days ago I dist-upgraded to lenny.
> > Everything works as expected except for xorg. No matter what I tried I
> > could not get past a blank screen. I expect this is related to bug
> > http://bugs.debian.org/cgi-bin/bugreport.cgi?bug=429432
> > 
> > I've tried everything from that is listed from the bug report but no
> > luck. I even tried downloading the r128 driver from etch and compiling
> > it from source but no luck.
> > 
> > Some notes:
> > 
> >  1. Using ATI Rage 128 M3.
> >  2. Works perfectly fine in Etch.
> >  3. I get as far as a blank screen but that is about it.
> >  4. Everything else works fine in Lenny (power management, etc).
> > 
> > I am having fun trying to accomplish my day to day tasks using the
> > command line but I need the GUI to use inkscape and rdesktop.
> > 
> > Any help is appreciated.
> > 
> > Thanks,
> > Amit
> > 
> > 
> Hi Amit,
> You don't say which version of the powerbook G4 you've. With my pb 3,3,
> I had a similar problem when i installed unstable and Ubuntu 8.04.  I've
> made a bug report on ubuntu launchpad.
> https://bugs.launchpad.net/ubuntu/+source/xserver-xorg-video-ati/+bug/220887

Thanks for the reply. I am sorry I couldn't get back to you sooner on this. Regarding the powerbook model, I have a Powerbook G4 500MHz Titanium I think. How do I find out the exact model (e.g pb 3,3 or pb 3,4) ?

> You'll find a workaround in the bug report. At the very least, you
> should get X with driver=fbdev

I tried using driver=fbdev and it works! Thanks for this tip. I checked out the bug report you posted and I browsed the git sources for xf86-video-ati and it looks like it fixes the issue for radeon based hardware. The GPU I'm using using the r128 driver. Also, r128 has a separate repo and the fix does not look like it has been propagated to r128.

As I'm writing this email, I am trying to compile the latest radeon drivers from the git master branch to see if I can use driver=radeon on this system. I will post back with the results that I get.

> good luck,
> Sébastien

Thanks for your help.

Reply to: