[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Re: Very weird results with X.org and fresh sid install

On Mon, Jun 2, 2008 at 1:00 PM, Rogério Brito <rbrito@ime.usp.br> wrote:
> Hi again, Bob.
> On Jun 02 2008, Bob Lounsbury wrote:
>> On Sun, Jun 1, 2008 at 11:57 AM, Rogério Brito <rbrito@ime.usp.br> wrote:
>> > On May 30 2008, Bob Lounsbury wrote:
>> >> dpkg-reconfigure xserver-xorg
>> >
>> > Thanks. "Been there, done that" before posting to the list (and before
>> > even pointing Ubuntu to the problem, which was some time ago).
>> Just to clarify (and sorry for insulting your intelligence), doing the
>> dpkg does not correct your screen resolution problem. Right?
> Using dpkg-reconfigure does not correct the screen resolution. I have
> already tried:
> * going back to kernel 2.6.8;
> * using the same modeline that the console uses (via fbset -x) in the
>  xorg.conf file;
> * setting and unsetting the flag to use the kernel framebuffer.
>> Or, it does correct the screen resolution, but you're trying to find
>> the root cause of why it wasn't correct in the first place.
> No, I still can't get that right. I filed a bug on
> xserver-xorg-video-ati and, luckily, Michel Dänzer replied. A new thread
> has been created on <debian-x@l.d.o>.
>> > The problem seems to be related with the r128 kernel and the ati driver
>> > from X and some interrelation between them. :-( There's some bad
>> > interaction there. :-(
>> The dpkg worked for me on Debian Etch about 2 weeks ago to correct the
>> screen resolution. If doing this on Debian Sid does not work, then I
>> agree with you there is some problem with the newer r128 kernel and
>> ati drivers.
> Which xserver are you using (version, I mean)? Since I still have no
> important data on this machine, I can experiment a bit.

The default etch xserver, which is at 7.1.0-19.

>> I've also installed or tried to install ... Gentoo, Arch, Fedora,
>> Yellowdog, Ubuntu, openSUSE, Slackintosh and CentOS on this machine.
> In my case, I just want Debian. :-)
>> Older versions of Fedora (around 6 & 7) booted up perfectly with the
>> correct screen resolution, but I just recently tried Fedora 9 and
>> could not get it to work.
> Which machine do you have? The same iBook G3 combo, Late 2001 that I
> have? In my case, I'm willing to go back as far as possible just to see
> where the problem lies.

Yeah, I think it's almost exactly the same model.

>> CentOS which I assume is an older X also didn't work and gave me the
>> typical 640x480 screen as you describe (it wasn't even big enough to
>> see anything to install it. I currently have Debian, Gentoo, and Arch
>> booting on this machine, but in every case I've had to copy my Debian
>> xorg.conf for use with Gentoo and Arch.
> Right. BTW, isn't CentOS just an unbranded RedHat?

Exactly. I just like to experiment :-}.

>> I would say the only ones that didn't have a problem with screen
>> resolution would be Fedora 6 & 7, Ubuntu, Yellowdog, and openSUSE.
> Nice to know, but which Ubuntu are you thinking about?

At that time it would have been 6.06, but since they decided to drop
the powerpc architecture then I dropped them :-}.

>> Hope it gets figured out. Although I assume interest in these aging
>> platforms is diminishing exponentially.
> As far as I am concerned, running new software on older hardware will be
> supported. :-)
> For instance, my packages will be running on m68k as long as these
> machines are available and I would even donate a PowerMac 9500/180MP
> with a G3 upgrade card as a buildd, if that would help Debian. Porting
> to more platforms just seems to expose bugs that wouldn't be noticed
> otherwise (e.g., see the problems that hfsprogs had with support for 64
> bit platforms).

I also didn't experience the same issues as Amit. Just yesterday I
decided (don't ask me why) to try to upgrade from stable to unstable.
I didn't have any problem with the upgrade from stable to testing, but
something got borked in the upgrade to unstable. I'm definitely not as
experienced as you are. Anyways, I didn't have any problem with X on
either testing or unstable (unstable was very brief, since something
didn't work ... I reinstalled stable and went through the same dpkg
song and dance to get a full display).


Reply to: