[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Re: Suspend to disk on iBook G4 (mid 2005)

Hi !

I tried again this "suspend-to-disk" thing with my mid-2005 12" iBook.
Everything I tried always ended up with the same result : if I try
this with the module "ohci-hcd" loaded, I get a kernel oops after
resume. If I unload it before suspending, it resumes ok, but then I
get an Oops when I try to reload this module....

Can anyone with the same computer confirm this behaviour ? Or should I
contact Apple because of a hardware problem ? I never have problems
with usb except this one...

Tanks in advance.

Best regards,


On 3/29/07, Johannes Berg <johannes@sipsolutions.net> wrote:
On Thu, 2007-03-29 at 14:08 +0200, Michel Dänzer wrote:

> > > It seems that I have a RV280 (from radeon man page).
> > > 0000:00:10.0 VGA compatible controller: ATI Technologies Inc M9+ 5C63
> > > [Radeon Mobility 9200 (AGP)] (rev 01)
> >
> > Doesn't that use r300 too?
> No, r200.

Oh ok.

> It definitely is in a lot of aspects, but not this one. :) The fix you
> mentioned was in the xf86-video-ati radeon driver and applies to all
> Radeon 3D drivers.


> It's available in xserver-xorg-video-ati 1:6.6.191-1
> which was uploaded to experimental recently. I'm afraid though it won't
> make a difference for suspend to disk, if only because you say you could
> reproduce the problem with glxgears running, which doesn't use textures.

Heh, good point. Yeah there must be something else broken. I also need
to retest is closing and restarting X still results in a totally borked
resolution (640x480)... so much to do, so little time...


Reply to: