[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Re: grub2 on powerpc

On Sun, Nov 19, 2006 at 09:53:00PM -0200, Otavio Salvador wrote:
> Sven Luther <sven.luther@wanadoo.fr> writes:
> > On Thu, Sep 07, 2006 at 06:35:24PM +0200, Robert Millan wrote:
> >> 
> >> Hi,
> >> 
> >> As you might know, experimental grub2 support has been added to d-i when using
> >> the expert mode, but it is only yet available on i386/amd64.
> >> 
> >> I made this patch to enable grub2 for powerpc as well, but unfortunately I can't
> >> test it (no ppc hardware here).  Would anyone like to try it?
> >
> > Hi Robert.
> >
> > Today i did a daily-build install on an apple XServe, and i wanted to give
> > grub2 a try, but i was not able to find any grub-installer package for
> > powerpc. I looked at the BTS, and grub-installer is only built for x86-ish
> > arches, and there is no grub2-installer.
> >
> > What am i missing here ? I thought you enabled powerpc support, and wanted
> > testing ? 
> Hey Sven,
> How are you doing?
> GRUB2 support was disabled by now since we're near of Etch
> release. You can reenable it and rebuild for testing.

Yeah, i know, the usual arch-conservatism. Doesn't make testing easy.

> If you want I can send you a source package ready but I think it'll be
> trivial for you. Currently we have grub-installer only bult for i386
> and amd64 but after etch is release I want to move to grub2 for
> default installations and then change the grub-installer archs.

Would have been more logical to have it enabled as non-default choice, and
then allow it to be tested easily.

I will see if i find time, but like said, the box is going into production,
and i may not have the possibility to test later on. Many others will be in
the same case.

BTW, can you look at the reason why partman is not setting the RAID flag on
powermacs ? Going into parted and setting it by hand worked, but there is
really no reason why partman should not set the flag himself. This is bug :

  #397973: [powerpci/mac] partman-md appears to not write back the raid flag
  to partitions.

I tried to have a look but couldn't find anything, and nobody else cares ...


Sven Luther

Reply to: