[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Re: Daystar Genesis MP Quad 604e mac clone with debian

It has 896MB RAM, a single internal SCSI drive and I've tried with
both an ixmicro twinturbo 128 card, and a rage pro, but neither make
a difference.

Any clues on which way to turn now?

Weird.... We do have support for the 4 CPU card in there. I'm not sure
what is wrong at this point.

What precise kernel version have you tried ? Also, what graphics card
are you using in this machine ? Have you tried BootX option "no video
driver" ?

I've tried both the 2.4 and 2.6 kernels from a Sarge netinst CD, the 2.6 from a recent etch netinst, and a bunch of kernels downloaded from ppckernel.org - trying to use any of the 2.6 kernels via bootx locks up at the same point - looks generally like: http:// www.danamania.com/temp/daystarfail26.jpg

The Sarge 2.4 kernel seems to be ignored by bootx and just drops back to MacOS after a few seconds (I'm pretty sure this is the same 2.4 kernel from the same CD that I used to install sarge on my 9500MP). That last behaviour looked suspicious, so I re-downloaded BootX direct to the machine just in case the copy I usually drag across the network was corrupted, but it did the same.

One of the 2.4 kernels downloaded from ppckernel.org (2.4.33-3) acts slightly differently to the rest, it drops to an xmon prompt - looks like http://www.danamania.com/temp/daystarfail24.jpg - is there anything I can do from there to diagnose what might be going wrong?

"no video driver" didn't look to do any different on any of them, (including dropping to the xmon prompt for that 2.4.33-3 kernel). I've tried all the kernels with the ixmicro twin turbo 8MB video card that the machine came to me with, and most of today's efforts were with a Mach64 card pulled from my current debian based 9500MP (2x180MHz PPC604). I don't have any of the same issues with Linux in that machine with that card - and the 9500 has a tanzania motherboard like the Daystar.

I've been using BootX 1.22 while booted to the finder into MacOS 8.1 and 9.1, and also as the BootX extension - I get the same screens each time.

It might be useful to try to netboot from OF instead. Might be more
reliable, and using OF over a serial port will probably provide better

You can do that by setting up a bootp/tftp server (enable the bootp
option in dhcp for the former, and install tftpd for the later) and
doing "boot enet". With a little bit of luck it will work on your OF
version (it works on most oldworld machines), at least provided you use
the on-board ethernet.

That sounds a little beyond anything I've tried before, so I'll shuffle off and read about it before attacking that side of things. Curiously, this Daystar doesn't show an openfirmware display with command-option-O-F, though I can type commands that it'll respond to, such as reset-nvram. Not come across that before, so again... more reading for me :)


Reply to: