[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

[bcm43xx] Two little issues

Hi there list,

I have bought very recently an Airport Extreme for my iBook G4 and I am
very satisfied with it: it worked without effort on the first shot using
the normal kernel on my Debian Sid install. I am using the firmware that
debconf suggested me to download after installing fwcutter (it comes from
a wl_apsta.o file).The performance is excellent (I managed 1.5MB/s
downloads from Debian servers ).

Two little problems (that arguably have the same solution) bother me

1) Sometimes when I boot my system, the airport is locked and gives the

SIOCGIFFLAGS error: no devices found

I have read around it should be a firmware problem (btw, fwcutter
complained about "getting a newer firmware version": any idea where to
find that?).
I have tried removing the bcm43xx kernel module, reinserting it and
restarting the networking but it does not work, the device remains
unavailable. The only cure is a reboot.

2) I can put my iBook to sleep (suspend to ram) and wake it without having
problems in resuming the connection (very impressive btw!!!). But if I
move out of the range of the AP I was connected prior to sleep, on wakeup
the card does not find any signal and I am forced (again) to reboot.

So I guess the question is: what is the right way to reinitialize the card
from scratch, without having to force a reboot? Thanks for your help!

Best Regards, Jack
Linux User #264449
Powered by Debian GNU/Linux on AMD64

Reply to: