[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Re: video problem with bootx on 7200


Thanks for your suggestions. Video works on the 7200 with bootx with a 2.4 kernel.

a) disable all extension (shift key down at macos
startup). saw report you could not use bootx extension
at startup with 7200 right ? (would be good to try
because with the bullet in front of the name it loads
early, i bilieve).

bootx seems to work ok either upon startup or started as an application after the os 9 boot is complete. I tried booting with extensions off then starting bootx after os 9 came up, and it booted into linux, but still had the same problem with the video.

d) all your 7200 parts, except for motherboard, are
compatible with several later models ...
so you have some options there - parting out or
replacing motherboard maybe.

I am going to give this machine away and I wanted to have Linux and Mac OS both working for the new owner, but I don't want to invest anything other than software install time, so I'm hoping to keep it in its current configuration.

g) try the current kernel for sarge (i don't
know what happened but you listed an older one)

I guess that's what was installed from the CD image I downloaded. I'm new to debian, my other machine is a 7500 with a 195MHz 604e upgrade card which started from a LinuxPPC 2000 install with updates built from source. I'm still trying to figure out the details of how apt-get works, but I managed to use it to install some different kernels.

I tried updating to this kernel:

Linux debian7200 2.6.8-3-powerpc #1 Sat Jul 15 11:50:29 UTC 2006 ppc GNU/Linux

and the video had the same problem.

Then I installed this:

Linux debian7200 2.4.27-powerpc #1 Tue May 30 22:50:15 UTC 2006 ppc GNU/Linux

With this 2.4 kernel, the video now works after booting with bootx (plus I get to watch all of the boot messages scrolling by, unlike with quik). Here are a few lines from the log:

Sep  5 00:10:42 localhost kernel: Total VRAM = 2MB 0011
Sep 5 00:10:42 localhost kernel: Monitor sense value = 0x717, using video mode 12 and color mode 1. Sep 5 00:10:42 localhost kernel: Console: switching to colour frame buffer device 100x37
Sep  5 00:10:42 localhost kernel: fb0: platinum frame buffer device

I wonder if it works because of some difference between the 2.6 and 2.4 kernels, or if it's because the machine is not booting from a ramdisk. For the 2.4 kernel in bootx, I unchecked the Use specified RAM Disk option and set the root device to /dev/sda2 which is where the linux filesystem is, and left the More kernel arguments box blank.

One thing I noticed is that when booting with bootx and the 2.4 kernel, the penguin logo is the correct color. When the logo appears after booting with bootx and a 2.6 kernel, the color palette is wrong, and depending on the monitor settings, it's usually a purplish color.

my understanding was that 7200 was not suppported
for mac os 9.1, so ...

As Charlie said, Mac OS 9.1 works on the oldworld macs, it's 9.2 and above that aren't supported.


Reply to: