[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Re: Bug#326220: libc6 2.3.5 ldconfig segfaults on powerpc oldworld

reassign 326220 apt

> Your system looks older than a testing from April 2005. libc6 version
> 2.2.5-11.8 is a libc6 from Woody, an Debian does not support direct
> Woody -> Etch upgrade.

So please reassign the bug to whatever seems appropriate. Not being able
to upgrade from woody to current testing/unstable is what I'd consider a
bug in its own right.

Besides, what's the proposed fix? etch ldconfig just doesn't work, so what
piece am I missing?

IIRC woody was still stable at that time, so it isn't all that outdated.

> > kernel version: 2.2.20-pmac (Debian package, unknown version)
> This is a rather old version, not even available in Debian Sarge.
> I suggest you to upgrade to Debian Sarge first (and also your kernel to
> a 2.4 or 2.6 version), before trying to upgrade to testing or unstable.

Well, apt or dpkg should have figured that out, and warned me off to not
attempt the upgrade, right? Yet another bug.

The system is booted using a floppy, I'm not sure I can even fit a 2.4 or
2.6 kernel on there. Either way, 'you should not try that' is not an
option if there's no warning during the upgrade. Once ldconfig has been
installed, the upgrade is shot. Nice way to tell your average user 'just
wipe the system and install ubuntu'. Debian used to pride itself on being
able to upgrade from oldstable to unstable without a hitch, and I've done
that before, even remotely.

Reassigning to apt, CC to debian-powerpc as a warning to others. Repeat
after me: 'it's not libc's fault if ldconfig breaks'.


Reply to: