[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Re: Booting on an Adaptec 2940 SCSI -- OldWorld

Simon Vallet <debian-ppc_user@castalie.org> writes:
> I'm currently trying to boot a beige G3 from a freshly flashed Adaptec
> 2940UW SCSI adapter. The linux side works fine when booting from
> another disk, but OF does seem to have some trouble, and just hangs
> forever -- several hours -- once a boot command has been issued.
> It *is* a mac version (2940UWPI), and has a nice path in OF:
> /pci/ADPT,2940UW/disk@0:0. I tried to reflash the card in the exact same
> machine with a 4.1 firmware, but still no luck...
> Does anybody here ever booted an OldWorld mac using such an adapter ?
> If so, anything particular to check, such as cables, termination etc. ?

I use one with 3.cantremember firmware in a 7500. Works just fine,
although it surely takes its time when enumerating all 16 device ids.
I also put it in a G3 once, but only to copy files from a SCSI disk to
the IDE disk of said G3, so I didn't boot from it, but it worked
otherwise in OS 8.6.

Thomas Jahns
"Computers are good at following instructions,
 but not at reading your mind."
D. E. Knuth, The TeXbook, Addison-Wesley 1984, 1986, 1996, p. 9

Reply to: