[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Re: USB wireless 802.11g dongle

Ciao Dean Takemori, nel tuo messaggio dicevi:

Unfortunately it turns out that the driver will not compile
against the Yellowdog 4.0 (2.6.8-1.ydl.7) ppc kernel.  I'm
no expert but in addition to probable endian problems, the
main issue appears to be x86 assumptions and asm usage.

On Dec 7, 2004, at 9:58 PM, Jack Malmostoso wrote:

Since you made me curious, I downloaded the driver and tried to compiled
it against my 2.6.9 custom kernel.

Actually, it compiled quite fine (lots of warnings, but no errors), but
when I tried to modprobe it I had some unresolved symbols: now I don't
know if this could be because I have no dongle yet, or if it is not
working on its own.

On Dec 7, 2004, at 11:11 PM, Dean Takemori wrote:

Trying to modprobe the module into the kernel gives

zd1211: Unknown symbol write
zd1211: Unknown symbol read
zd1211: Unknown symbol open
zd1211: Unknown symbol close

I've also tried to compile and load the driver on an Athlon-XP box
running FC 1 (2.4.22-1.2199.nptl) kernel.  Same compilation warnings
but the module loads cleanly.  (Whether or not it actually works
with the hardware is another issue)

I did some Google research and came up with this thread:


I'm unsure as to the correct fix (patch the kernel to export the
functions or find a more correct way to program around the missing

BTW, the same problem occurs with YDL 4.0 update kernel 2.6.9-1.ydl.8

-dean takemori

Reply to: