[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Re: installing debian on IBM 43P-150 (CHRP)

On Thursday 02 December 2004 12:27, Leigh Brown wrote:
> Philippe Guyot said:
> > On Thursday 02 December 2004 12:01, Leigh Brown wrote:
> >> Indeed.  Could you just tell me if it booted from CD automatically?
> [...]
> >> I guess I can raise a bug for these once I've confirmed that autoboot
> >> from CD is working for you.
> >
> > Good news: It boots automatically
> Great!
> > Bad news : At end,the install said there was not stuff for booting
> > automatically from HD this hardware and that I have to boot /boot/vmlinux
> > on /dev/sda1 whith argument root=/dev/sda1.
> Okay.  Did you create a PReP boot partition (type 0x41) during the
> installation process, either manually, or with help from the installer?
> > I  tried from OF boot disk;:/boot/vmlinux root=/dev/sda1  with no success
> > (return to prompt after accessing HD a little)
> That's because OF doesn't understand ext2, ext3, and the like.
> > May I have to boot yaboot from cd ?  and after ??? I should read yaboot
> > man page, don't I  ?
> If you already have a PReP boot partition, as I mentioned above,
> then you can boot the installer and drop into a shell to install
> yaboot into it.  Otherwise, I'd repeat the installation, this time
> making sure to create the PReP boot partition.  Also, make sure
> yaboot is installed during the installation.  With luck, having the
> correct boot partition and yaboot installed might trigger the installer
> to do the right thing.  If not, drop back into a shell at the end of
> the installer and manually setup and configure yaboot before rebooting.
> Reading through the yaboot docs before this may make things easier.

Well, do you mean that the CHRP box boots like a PReP machine ?
And if so, why not dropping in the PReP partition the vmlinux patched whith 
preptools as I did for my 43P-140 ?

Reply to: