[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Re: Memory and hard disk testers

On Sat, 20 Nov 2004, Mehul N. Sanghvi wrote:

> Mehul N. Sanghvi wrote:
> All right, so I tried it out, and nothing happens.  I did a test run
> on my UltraSPARC 2 at the office where it worked just fine.
> I ran it as:
>     root# memtest all -l
> after which I get a screenful of things where it says it can't
> mlock the size of the memory.  I have 768 MB.  It then got down
> to a size that it could mlock and proceeded to do so, but
> nothing happened.  Everything just got frozen.  Any ideas
> as to why that would happen (besides the fact that the memory could
> be bad).
> cheers,
>       mehul
 I've been playing with 2.93.1 and 4.0.4 this weekend (the output screen
from 4.0.4 looks a bit nicer, but it doesn't do logging and gets
confused by 'all').  Once you've got a size of memory that it is able to
mlock, and assuming you are running in single user mode without swap,
I'd go with bad memory.  Sorry.

 Alternatively, if your cooling is marginal you might lock when the cpu
overheats.  Or perhaps the power supply isn't up to the job.  I forget
what you have, but both these problems are unlikely on sane hardware,
even my AmigaOne can get through hours of memtester without locking
(although hefty compiles with gcc-3.4 are a different story).

 das eine Mal als Tragödie, das andere Mal als Farce

Reply to: