[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Re: Test patch for sleep on Aluminium PowerBooks


* Federico Gamio <federico@gamio.net> [2004-11-12 09:47 +0100]:
> On Fri, 2004-11-12 at 15:49 +1100, Benjamin Herrenschmidt wrote:
> > On Fri, 2004-11-12 at 02:40 -0200, Federico Gamio wrote:
> > 
> > > One simple question.
> > > Haw can I debug the sleep process or wakeup process?
> > 
> > It's usually quite complicated ... I wouldn't know how to explain things
> > in an email list that... 
> > 
> > Have you tried pristine 2.6.9 with my patch and no pbbuttonsd nor pmud
> > (just using snooze -f) ?
> Done Ben, and guess what?
> It works.
> The problem is solved when you don't apply swsusp patch.
> So, you can't apply swsusp patch if you want suspend to ram in
> Powerbooks :)

yes, my kernel does not have the swsusp code patched into it, either.

using pbbuttonsd, i just tried to resume after a 12h sleep and the system
froze with the display being visible:

hda: ...
hdc: ...
eth0: ...
usb 1-1: control timeout on ep0in

USB device 1-1 is, according to /sys/bus/usb/devices/1-1, the Bluetooth

> Right now it works with snooze -f and with pbbuttonsd

Frederico, would you please try to attach a USB device (and unattach) and
try again?
for now, every resume worked for me when invoking snooze in these
- resume after a couple of seconds:
  + no USB device
  + USB device attached
  + USB device attached previously

- resume after 10 minutes:
  + USB device attached previously

so using snooze from the package "pmud" seems to make a difference...
btw, users of pbbuttonsd, download the package pmud by hand (to prevent
pbbuttonsd being uninstalled), unpack (ar -x) the .deb and unpack
data.tar.gz to find snooze in sbin/.

::: .O.
::: ..O
::: OOO
::: lynx -source http://www.kodeaffe.de/shensche.pub | gpg --import

Attachment: signature.asc
Description: Digital signature

Reply to: