[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Re: Powerbook G3 and linux - boot CD problem


Mariusz writes:

> I have PowerBook G3 300Mhz, Family Number m4753.

This is a Wallstreet.  G3 PowerBooks are commonly referred to by their

> I try run a linux on that laptop. I took Knoppix ppc, Mandrake PPC,
> and debian sarga. I have one common problem - I can't start from CD
> - I don't have any idea about mac, somebody give me it some days
> ago.  I found that suppostu start when I keep "C" - but not.

Unfortunately, your machine is OldWorld.  Therefore it cannot, and
never will be able to, boot Linux from CD.

> Finaly I run BootX whith I took from Internet. Those BootX what I
> found on the CDs doesn't run. I run Bootx with kernel 2.4.20 from
> knopix but on that moment it crash during start up:

> vfs cannot open root device or 16:01
> please append a correct "root=" boot option
> kernel panic: VFS: unable to mount root fs  on 16:01

Looks like you need to feed a ramdisk of some sort into BootX along
with the kernel.  Look on the CD near the kernel you used.  If you
don't find anything useful, try the vmlinux and initrd.gz files from

Regards, Jens.

J'qbpbe, le m'en fquz pe j'qbpbe!
Le veux aimeb et mqubib panz je pézqbpbe je djuz tqtaj!

Reply to: