[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Re: Powerbook G3 and linux - boot CD problem

On (05/10/04 12:16), kajko04@gazeta.pl wrote:
> Hi.
> I have PowerBook G3 300Mhz ,Family Number m4753.
> I try run a linux on that laptop. I took Knoppix ppc, Mandrake PPC, and debian 
> sarga. I have one common problem - I can't start from CD - I don't have any 
> idea about mac, somebody give me it some days ago.
> I found that suppostu start when I keep "C" - but not.
> Finaly I run BootX whith I took from Internet. Those BootX what I found on the 
> CDs doesn't run. I run Bootx with kernel 2.4.20 from knopix but on that 
> moment it crash during start up:
> vfs cannot open root device or 16:01
> please append a correct "root=" boot option
> kernel panic: VFS: unable to mount root fs  on 16:01
> When I try use this file what is on the KNOPPIX CD in BootX to set as kernet 
> it is not active.
> Please help me run linux on that MAC
> Thanks for any idea.
> Mariusz
Hi Mariusz

You could try booting whilst holding down cmd+opt+shift+delete - tells
your Mac to skip the first bootable device.  If holding down C doesn't
do it.  

Is it new world or old world? If is one of these:
PowerBook G3 FireWire Pismo (2000)              powermac-NewWorld
PowerBook G3 Lombard (1999)                     powermac-NewWorld 
it's new world

BootX doesn't work on new world.

If you can't boot off a CD, you can boot off the hard disk by following
the instructions here:

4.4.2 Hard Disk Installer Booting for NewWorld Macs



Byte-Night 2004 ... helping the young homeless .. please visit:

Reply to: