[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

ALSA on TiBook IV spitting out garbage?

Ok, so I compiled a kernel with all the ALSA stuff enabled as a module, and I can get the mixers to work and the computer DOES play sound... it just plays garbage (kinda like a heartbeat monitor with ALOT of static).

Anyways... I'm fed up with monkeying with it, and figured I should ask the experts (that's you).

I ran alsaconf and it set it up and all that good stuff (installed alsa-utils and alsa-base via apt-get, unstable.  Kernel is 2.6.6 with alsa compiled in).

Here's what lsmod tells me:
Module                  Size  Used by
dmasound_core          20484  0
ds                     19400  0
yenta_socket           20388  0
pcmcia_core            62244  2 ds,yenta_socket
i2c_keywest            10052  0
snd_powermac           38404  3
snd_pcm_oss            64676  1
snd_mixer_oss          20896  3 snd_pcm_oss
snd_pcm               108156  2 snd_powermac,snd_pcm_oss
snd_page_alloc         10892  1 snd_pcm
snd_timer              25180  1 snd_pcm
snd                    56564  5 snd_powermac,snd_pcm_oss,snd_mixer_oss,snd_pcm,snd_timer
soundcore               9320  5 dmasound_core,snd
airport                 5856  0
orinoco                51276  1 airport
hermes                 14368  2 airport,orinoco


so all the modules seem to be loading correctly...

annnnd... here's my /etc/modprobe.d/sound file:
options snd  device_mode=0660
alias snd-card-0 snd-powermac
alias sound-slot-0 snd-powermac

and I tried using a /etc/modutils/alsa file,but it didn't work (it looks like this):

alias char-major-116 snd
options snd  device_mode=0660
alias snd-card-0 snd-powermac
alias char-major-14 soundcore
alias sound-slot-0 snd-card-0
alias sound-service-0-0 snd-mixer-oss
alias sound-service-0-1 snd-seq-oss
alias sound-service-0-3 snd-pcm-oss
alias sound-service-0-8 snd-seq-oss
alias sound-service-0-12 snd-pcm-oss

any ideas?
fn:Justin Dittmann
adr:;;640 North Henry Street;Madison;Wisconsin;53703;USA

Reply to: