[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

iBook 2.2 with new board, full of problems

I am a student from north Spain state, and I am having big
problems with my computer, I'll give you dates.
(sorry about my very low english level)

Last year, in summer I bought an iBook:

PowerPC G3 900Mhz; 512 cache level 2
128 MB SDRAM + 256 | 40GB HD
XGA TFT, 12,1
32 video RAM, ethernet, 56k modem, airport, etc.

Since I bought it I was running debian GNU/Linux sid, I installed with
the woody ppc NONUS CD1, and upgrade to sid, all was working very well,
but 2 months ago, I was working  with the iBook and the screen got
frozen, system too, when I rebooted the screen was blank, I knew the
problem of the display failure so I went to the shop where I bought my
machine, and talk them about the failure recognized by apple.
In 2 weeks I had my machine repaired.

I went home, and when I tried to install woody again, system crashes,
screen got frozen in the installer... 
I rebooted, and system booted ok.
osx was working but woody ppc installation failled all times.
Some times I obtained error messages, other the system got too hot and
halts. It was imposible to install debian.

Newly I went to the shop where I bought iBook.
They dont support linux, so I had some problems with them, they told me
that the board was the same that before, so I thought that if the board
was the same but without display failure, it must were a hardware
failure issue, and I told them to look for hardware errors.
Days later they gave me the computer and I paid 50 euros (like dollars)
cause they did not found errors, I paid with guaranty...
There were an error, cause the board of my ibook is newer than previous,
and they said me that it was the same, that is the reason cause I paid
50 and not 100 euros (tech service), cause they recognized their fault.
I am displeased with that people.

After that a guy in debianppc channel at freenode irc server said me,
that probably if the board is newer, it could be not yet supported in
woody installer that uses 2.2 ppc kernel and recommend me to try with
this installer:

I installed woody with XFS and...
Yeah!, it was working OK, I installed debian, I upgrade to sid,
installed my favourite desktop and software, all seems to work without
problems, but when I was compiling 2.6.3-ben2 kernel, I obtained
different messages like:
"Internal compiler error", or "Segment fault".
Curiously in one of the tries of kernel compiling, all worked OK, then I
start to doubt if it was a hardware failure issue.
I made a memory test using sysutils, memtest at kernel init, and errors
found was 0.
Today I was looking for evidences of what is happening in my
computer/system and I try to compile the system with the iBook in the
garden (here is snowing so the temperature is very low), the result was
that the compilation sucess without errors.
After I made it newly in my house, with the ibook temperature higher and
compiling failled again.
I test out of my house 2 times with the iBook cold, both times compiling
finished OK, the rest of the times, there were errors.

I have segment fauls using apt-cache too, if I upload aplications from
memory, this problem seem to disappear, but the are many other problems.

So, I cant use my computer normally, sometimes if the iBook get hot
aplications crashes, today a DVD playback crashed, gnome-terminal
crashes in one compiling test, yesterday my screen got frozen...
I dont know what to do, cause all this problems only happen when system
temperature is high, and since the motherboard was changed. 
Here I put you my /proc/cpuinfo

processor       : 0
cpu             : 750FX
temperature     : 12 C (uncalibrated)
clock           : 900MHz
revision        : 2.3 (pvr 7000 0203)
bogomips        : 1785.85
machine         : PowerBook4,3
motherboard     : PowerBook4,3 MacRISC2 MacRISC Power Macintosh, 
detected as     : 257 (iBook 2 rev. 2)
pmac flags      : 0000000b
L2 cache        : 512K unified
memory          : 384MB
pmac-generation : NewWorld

Before my board was changed, clock mostly was in 400mhz, except when cpu
was working hard, now allways is 900mhz.
I cant give you more dates...

If somebody know more test to do in my machine, say me when as posible,
I would like to know if it is a hardware failure (again), or a hardware
issue relationed with linux support.

       .:: Tierra pertenece a nadie - Earth belongs nobody ::.
 Alberto Viniegra Ilarregui
 PGP Public Key: http://sindominio.net/~lobezno/lobezno@SD.asc
 Huella de clave = 2C37 EBF0 2D92 C792 76BF  4A62 2BAD 0A84 EDF7 DF2E
 Debian    http://www.debian.org
 GNU/Linux http://www.gnu.org  http://www.linux.org
 http://wildness.mine.nu (void)

Reply to: