[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Re: Is Audacity working for anyone?

On Sun, 2004-02-15 at 14:17, Gregory Seidman wrote:
> On Sat, Feb 14, 2004 at 09:45:10AM +0100, Joe Malik wrote:
> } On Sat, Feb 14, 2004 at 12:35:25AM -0500, digger vermont wrote:
> } > Hello All,
> } > 	Does anyone have audacity working? In particular for me the playback is
> } > horribly distorted.  
> } 
> } 
> } audacity from unstable seems to introduce a bug manifesting here as 
> } playback is distorted, where the version from testing plays nicely.
> } You migt wanna give testing a try.
> [...]
> I've experienced the same thing with my PPC 604. The sarge version works
> fine, the side version is not so much distorted as pure static. I will
> note that on x86 there is no problem with either version.
> --Greg

Thanks Joe and Greg for the info.  

I tried 1.0.1 from testing and it does playback okay.  The features are
on the sparse side though.  This is probably going over old ground but I
did trace it to an endian problem.  

I decided to compile different versions to see where it fails.  Right
off the bat the source for 1.0.0 from the audacity site played back with
the same "noise".  The only difference was a test to set big or little
endian. adding that solve the problem.

Unfortunately, the next higher version seemed to be completely rewritten
and the same simple fix doesn't work.

At this point I'm hoping that if I can compile audacity with alsa and
jack support it may work.


Reply to: