[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Re: ybin fails

begin  Thomas Krennwallner <djmaecki@ull.at> wrote:
> Joerg Sommer <joerg@alea.gnuu.de> writes:
>> I had the same problem. Since an upgrade to 2.6.0-ben2 these problems
>> are gone.
> Hm, before I run into the problem I had 2.4.22-4 running (yaboot
> 1.3.10-2.1). Then I installed yaboot 1.3.11-1 but didn't run
> ybin. Yesterday I tried 2.6.1-rc1 and 2.6.1-rc1-ben1. Neither of them
> let me update nvram via ybin. I booted old 2.4.22-4 and tried to run
> ybin with the same error.

Difficult. But this isn't a problem with yaboot. ybin calls nvsetenv
which brings this error. So check if a newer powerpc-utils version then
yours is available.

Does nvsetenv work for you the first time? At me, I could call nvsetenv
the first time without problems, but a second call brought an error. But
all this is gone since the kernel upgrade.

$ dpkg -l yaboot powerpc-utils 
| Status=Nicht/Installiert/Config/U=Entpackt/Fehlgeschl. Konf./Halb install.
|/ Fehler?=(keiner)/Halten/R=Neuinst. notw/X=beides (Status, Fehler: GROß=schlecht)
||/ Name           Version        Beschreibung
ii  yaboot         1.3.11-1       Yet Another Bootloader
ii  powerpc-utils  1.1.3-7        Various utilities for Linux/PowerPC
$ uname -a
Linux ibook 2.6.1-rc1-ben1 #1 Fri Jan 2 15:15:31 CET 2004 ppc GNU/Linux

What says ltrace (or strace)? Where occures the error?

Wenn du nur einen Hammer hast, sieht jedes Problem aus wie ein Nagel.

Reply to: