[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Re: [LONG] new 15


Wright G.(N) a écrit:
Hi all,

Whilst I don't use Debian on my PowerBook G4 (I use Gentoo), I'll still post my experiences as they are
essentially generic across all distros :) Be warned, some of this info may be a bit out of date - they are from my experiences a month ago (deleted linux when I sent it in for white spot repair and I'm reinstalling it right now as I type :)..

Mine was in Holland for the screen too. But with Linux installed :-)

First, 2.4.x doesn't work too nicely (obvious) but 2.6.0-testX works fine (brightness buttons, volume control etc).

For me, all was working with the 2.4.X, excepted XFree.

I got the eject key to work by changing the value of the keycode in the pbbuttonsd config to the value shown by

I've tested pbbuttons, and it doesn't work as well as ikeyd. Only the eject_key dont work.

"showkey". Eject worked fine after that. I have a feeling that the maximum brightness in Linux isn't as bright as it
is in Mac OS X - any ideas?

With ikeyd, I have the 15 bright levels, like in Mac OS X. But no way to configure the keys like with pbbuttonsd.

About headphones, they don't work brilliantly. Yes, when I plug in the headphones the internal speakers mute and the
audio is sent to the headphones, but if I change the volume with the volume keys with the headphones plugged in,

Yes, a little echo sometimes, but it's working very correctly the rest.

the audio comes out the internal speakers again. No idea if this is a pbbuttonsd/kernel/powerbook issue, but I seem to remember I didn't have the trouble if I used kmix instead of the volume keys. Haven't tested line in..

with Mac OS, line in give me a Larsen effect :-/ So I'ts not active, and I don't even need this "feature".

FireWire 400 worked fine with my external hard disc. Like the previous poster, I don't have any 800 devices to test..
Graphics worked fine with 2.6.0 and XFree86 from CVS. Wouldn't work with one or the other - I needed both on for it

Yes. I have an ieee1394 HD, and itworks very well. High speed. Not tested the DV, but something let me think it OK too.

to work. 3D accel didn't work (as expected) and I got about 120fps in glxgears iirc..

114 for me  :-p

Clock slewing not sorted out yet - machine runs at 765MHz with a FSB clock of 102MHz. /proc/cpuinfo lies about it
being 1250MHz :) You can tell this because the bogomips rating is way down in the ~750 region, when it should be up

This point is the most interessant for me : how can you know all this speeds ?

For me :

eric@alube:~$ cat /proc/cpuinfo
processor	: 0
cpu		: 7457, altivec supported
clock		: 1249MHz
revision	: 1.1 (pvr 8002 0101)
bogomips	: 761.85
machine		: PowerBook5,2
motherboard	: PowerBook5,2 MacRISC3 Power Macintosh
detected as	: 287 (PowerBook G4 15")
pmac flags	: 0000000a
L2 cache	: 512K unified
memory		: 512MB
pmac-generation	: NewWorld

Seems to be correct, for me, even if my ibook give me 1389 BogoMips

Keyboard seems to work fine with all the keys... Backlighting doesn't work. Trackpad etc works..

ie for me.

Haven't tested PCMCIA, but I presume it works as it seems to be the same as on the tibook? Haven't tested DVI out

I've a Belkin F5D6020f ver.2 with Atmel chipset inside, but don't work, ...perhaps my configuration is not correct.

modprobe atmel_cs

What else ? I've installed all the packages for PCMCIA...and I don't know where I am wrong. (BTW : Is someone on this list using this card with a powerbook ?)

either, and I don't expect it to work. USB/USB2 seems to work fine (OHCI for USB and EHCI for USB2 afaict)..

I've seen the right USB connector is not as stable as the left one. For the wifi, the MA111 now works fine (without WEP for now, because I've not read the docuemntation...soon I will :-).
It works with linux-wlan-ng-0.2.1-pre15.

SuperDrive should have no trouble working with scsi emulation. Haven't tried it yet, but I don't see why it
shouldn't work..

For now, ide-scsi don't work, but xcdroast recognize the SD. So I can burn something. Not tested yet

Regards, eric bachard

NO ePATENTS / NON AUX BREVETS SUR LES LOGICIELS. See / Voir http://swpat.ffii.org/

Reply to: