[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Re: [LONG] new 15

Hi all,

Whilst I don't use Debian on my PowerBook G4 (I use Gentoo), I'll still post my experiences as they are essentially generic across all distros :) Be warned, some of this info may be a bit out of date - they are from my experiences a month ago (deleted linux when I sent it in for white spot repair and I'm reinstalling it right now as I type :)..

First, 2.4.x doesn't work too nicely (obvious) but 2.6.0-testX works fine (brightness buttons, volume control etc). I got the eject key to work by changing the value of the keycode in the pbbuttonsd config to the value shown by "showkey". Eject worked fine after that. I have a feeling that the maximum brightness in Linux isn't as bright as it is in Mac OS X - any ideas?

About headphones, they don't work brilliantly. Yes, when I plug in the headphones the internal speakers mute and the audio is sent to the headphones, but if I change the volume with the volume keys with the headphones plugged in, the audio comes out the internal speakers again. No idea if this is a pbbuttonsd/kernel/powerbook issue, but I seem to remember I didn't have the trouble if I used kmix instead of the volume keys. Haven't tested line in..

FireWire 400 worked fine with my external hard disc. Like the previous poster, I don't have any 800 devices to test..

Graphics worked fine with 2.6.0 and XFree86 from CVS. Wouldn't work with one or the other - I needed both on for it to work. 3D accel didn't work (as expected) and I got about 120fps in glxgears iirc..

Clock slewing not sorted out yet - machine runs at 765MHz with a FSB clock of 102MHz. /proc/cpuinfo lies about it being 1250MHz :) You can tell this because the bogomips rating is way down in the ~750 region, when it should be up in the ~1200 (I believe). The kernel needs a driver written for cpufreq that will work with this machine. Until then I'm using distcc between my tibook and albook :)

Keyboard seems to work fine with all the keys... Backlighting doesn't work. Trackpad etc works..

Haven't tested PCMCIA, but I presume it works as it seems to be the same as on the tibook? Haven't tested DVI out either, and I don't expect it to work. USB/USB2 seems to work fine (OHCI for USB and EHCI for USB2 afaict)..

SuperDrive should have no trouble working with scsi emulation. Haven't tried it yet, but I don't see why it shouldn't work..

Ethernet works and AirPort Extreme doesn't (bloody broadcom!). 

Bluetooth is recognised as an "unrecognised USB device" according to dmesg, but I don't have any bluetooth stuff so I don't care :)

Sorry if any of this information has already been mentioned..



Harrow School does not accept responsibility for email contents. This email and any attachments are intended only for the addressee(s) named above and may not therefore be disclosed to any other person. If you are not the named addressee, please delete or destroy all copies whether in electronic or hard copy form and telephone Harrow School immediately or email us on postmaster@harrowschool.org.uk including message headers if possible..


Reply to: