[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Re: [LONG] new 15" powerbooks and XFree : success

hi list...

i just wanted to add some info about my 15" albook to this..

* "eric.bachard@b.org" <eric.bachardNOSPAM@free.fr> [2003-12-06 14:54 +0100]:
> What can work for now ?
> - Audio CD's are working too (with xine -H). External HP work too.
> (Not tested Audio-in)

hm, that does not work for me. i can play CDs, but cannot hear them (in
contrast to playing internet-radio, ogg, system-sounds). there is no
channel for CD seen in the alsamixer. i tried to upgrade to alsa
1.0.0rc1 once which did not seem to be compatible to kernel
2.6.0-test11-benh (last week) which comes with alsa 0.9.7. perhaps you
are using the OSS module (dmasound_pmac)? well, somewhere, there must be
a newer version of alsa than 0.9.7 for 2.6.x...

> The screen luminosity (F1, F2) and the sounds buttons (F3 F4 F5) are 
> working too.  The eject button don't work for now.

well, pbbuttonsd does not work for me when it comes to the buttons. the
luminosity works as long as there is _no_ pbbuttonsd running. volume,
eject and power buttons are ignored, although the generated keycodes
match with the ones defined in the config file. except the
eject-button which generates several keycodes at once. perhaps my
slightly modified i386-qwertz-de-latin1-nodeadkeys keymap has something
to do with that?
fortunately, i work a lot with gnome and acme is really helpful, then.

> What "can, but not sure" work :
> Bluetooth

hm, sort of works. but not really. when i load the module, i get this:

Bluetooth: HCI USB driver ver 2.4
bus usb: add driver hci_usb
bound device '2-1:1.0' to driver 'hci_usb'
hci_usb: probe of 2-1:1.1 failed with error -5
hci_usb: probe of 2-1:1.2 failed with error -5
drivers/usb/core/usb.c: registered new driver hci_usb

hci0 can be upped but then dmesg shows this:
hci_usb_isoc_rx_submit: hci0 isoc rx submit failed urb e3931e14 err -22

afterwards, i can l2ping my mobile phone. though i get a reply with 0 bytes
the sdptool also discovers all services offered by the phone.
but rfcomm does not work at all, but this could be a user-space problem
as it complains about a not-found configuration for rfcomm0. which is
definitely there and is read by rfcomm.
anyway, the README of bluez-utils says that they currently focus on 2.4.


works great. tried with wlan, lan and modem cards.

> IEEE1394.

works with my external harddisk, too. at least in S400, do not have a
device for S800.
although i get a trace when loading ohci1394:

bus pci: add driver ohci1394
ohci1394: $Rev: 1045 $ Ben Collins <bcollins@debian.org>
ohci1394_0: Unexpected PCI resource length of 1000!
ohci1394_0: OHCI-1394 1.1 (PCI): IRQ=[40]  MMIO=[f5000000-f50007ff]  Max
bad: scheduling while atomic!
Call trace:
 [c000bb28] dump_stack+0x18/0x28
 [c0017d44] schedule+0x81c/0x820
 [c0007dfc] syscall_exit_work+0x108/0x10c
 [d6633d48] 0xd6633d48
 [f5461c4c] nodemgr_add_host+0xac/0x11c [ieee1394]
 [f545d46c] highlevel_add_host+0xac/0xb4 [ieee1394]
 [f545c67c] hpsb_add_host+0x80/0xc0 [ieee1394]
 [f5093148] ohci1394_pci_probe+0x38c/0x4f4 [ohci1394]
 [c00dc5dc] pci_device_probe_static+0x6c/0x8c
 [c00dc64c] __pci_device_probe+0x50/0x70
 [c00dc69c] pci_device_probe+0x30/0x60
 [c00fa7e4] bus_match+0x50/0x8c
 [c00fa964] driver_attach+0x88/0xc8
 [c00facfc] bus_add_driver+0xa4/0xf4
 [c00fb194] driver_register+0x30/0x40
bus ieee1394: add device fw-host0
ieee1394:Hostadded:ID:BUS[0-00:1023] GUID[000a95fffedc19b2]

well, i will post this on the somewhen next year on the firewire-ml,
when the things not yet working got somewhat fixed. :)

ok, i think i will tackle the bluetooth issues next, as they seem the
most pressing to me. but beforehand i am trying to fix the problems with
yafc, as you can see at BTS #222632.

::: .O.
::: ..O
::: OOO
::: lynx -source http://www.kodeaffe.de/shensche.pub | gpg --import

Attachment: signature.asc
Description: Digital signature

Reply to: