[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Kernel hangs during boot on PowerBook G4 17 1GHz

I have been trying to get a 2.4.23(pre5_benh?) kernel up and running on a PowerBook G4 17". Currently I can get through the following steps without issue:

make clean
make menuconfig
make dep
make-kpkg --revision benh.1 kernel-image
cd ..; dpkg -i *.deb

	However, upon reboot, I always see something along the following lines:

input3: ADB HID on ID 3:3.01
adb: finished probe task...
INIT: version 2.85 bootlog
hub.c: new USB device 10:1a.0-1, assigned address 2
usb.c: USB device not responding, giving up (error=-32)
Starting Bootlog daemon: hub.c: new USB device 10:1a.0-1, assigned address 3

This is the most informative of the specimens I have seen. Usually, the hang occurs right after the line that starts "hub.c:". I have tried paring down the kernel config USB support to nothing more than OHCI, and I have tried adding things back, but I have yet to figure it out. An attempt to match the PowerBook G4 12" kernel config at http://www.mathematik.uni-marburg.de/~schmidtm/apple/powerbook.en.php didn't work out for me, either. (I know, there are some hardware differences, but I was running out of ideas) I have compiled about 8 or 9 times today, so I gave it a good try, but I am mostly doing guesswork. So, if anyone has any suggestions, or even better if you already have a great kernel config file for a 17" PowerBook G4 1GHz, feel free to share.

Barry C. Hawkins
All Things Computed
site: www.allthingscomputed.com
weblog: www.yepthatsme.com

Reply to: