[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Re: starmax 3000 boot settings

On Tue, Mar 04, 2003 at 02:18:31PM +0000, Nicholas Helps wrote:
> Hello all,
> This is no doubt old hat to all you dyed in the wool linux people, but I'm fairly new to the game and so I am 
> having a few problems. I'll briefly tell you what I have done and where I have gotten stuck at.
> Downloaded woody CD images (first two only for the time being - CD#1 is NONUS version) and burned ISO images. 
> Downloaded the two boot install images and made floppies.
> Backup up all my Mac OS stuff off my internal IDE (1.2GB) HD.
> Inserted floppy 1 and booted. Inserted floppy 2 at request and got to install menu.
> Chose language, chose kbd, etc and made it all the way through to make system bootable. As far I could tell 
> everything was fine and I installed the base system and kernel. I partitioned the HD so that there is a partition 
> map at hda1(few KB), a linux native at hda2 (1.1GB) and a linux swap at hda3 (100MB).
> Once I made the system bootable (using quik), I restarted. The first time I did this all I got was a blank screen. 
> I then went off and read about quik and open firmware. I also tried zapping the pram. This didn't help.
> I then booted back into the boot floppies and once everything got going, I opened a second consol and used 
> nvsetenv to look at and alter the firmware:
> Set input/output devices to kbd and screen.
> Auto-boot left set at true.
> Set boot-device to ata/ata-disk@0:0
> no boot-file set

Set boot-file to Linux, and after a few seconds quik will choose that for you.

Linux (capital L) is the name of the image section in the default quik.conf.

> On restart I get a white screen with some text on it about quik second stage boot, woody.., then a boot: prompt. I 
> tried entering "linux", "boot", "vmlinux". It kept asking for a path to the kernel. So I tried things like 
> dev/hda2/vmlinux, etc. None of these worked.

quik doesn't cooperate very well when manually naming kernel paths. 
It's much better at picking images from quik.conf.

> Back into the install process again and using a second consol showed that there does not appear to be a linux 
> kernel on the HD. From what I understand it should be at the root (/) directory. All there is at that place is 
> "rclinux". There is no "vmlinux". From what I read, this is what the kernel should be called. The install manual 
> mentions very little about anything like this and basically says quik will set up everything.

The system you are installing appears under /target inside the installer.
You would find /target/etc/quik.conf and /target/vmlinux. Check that
the quik.conf points to a kernel in /boot/, or else cp the kernel file
physically to / and then change the quik.conf to match. To install quik
within the installer shell, do 

cp /target/etc/quik.conf /etc/quik.conf
quik -v

> Presumably I am missing something very simple. I did see a "quirk" of "quik" for the starmax where it said what 
> the boot-device should be set to (as above) and somewhere else that is said you usually do not need to set a 
> boot-file.
> To be honest, I am getting lost in all the firmware and quik stuff. As I said above, I can't find vmlinux anywhere 
> on my HD and I also can't find a quik.conf file. Without either of these, I would imagine that linux can't boot. 
> It might also explain why all the common suggestions for solving problems by entering "default values" (like 
> debian, or linux, or vmlinux) don't work.

vmlinux is normally a symlink to the real kernel file in /boot.
Since quik doesn't do symlinks, your quik.conf should not point
to vmlinux (the symlink). It should point to the real kernel
file - which may be more easily found at the root level where
vmlinux sits. I'd recommend copying your kernel file from /target/boot
to /target as I mentioned above, just to eliminate the possibility
that quik is not reading the filesystem properly.
"The way the Romans made sure their bridges worked is what 
we should do with software engineers. They put the designer 
under the bridge, and then they marched over it." 
-- Lawrence Bernstein, Discover, Feb 2003

Reply to: