[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Re: About the latest Ibook, problems...

On Sam, 2002-12-28 at 18:42, Miguel Sousa Filipe wrote: 

> I have problems with the X .. can't get it working .. i'm using ben's kernel,
> I have 1024x768 on the console, radeonfb it seems.. and i have a radeon module
> wich I believe is the DRI driver right?
> I've seen some web pages with XF86Configs but it gives me allways a working
> mouse, with a foreground somewhat broken.. strange colors, mouse button is a
> square, ..it's pretty unusable.. the mouse seems to respond to the trackpad..
> but that's it, can't go to the console.. and can't to squat in X.. i've tried
> killing X from ssh.... but it stays the same.. with the exeption of the mouse
> wich stops responding.. and still.. I can't get out of it.. basically..
> Everytime I try to run X I get stuck, and the only way out is to reboot, or take
> the batery off.
> - - Should I have the radeon module running before running startx ?
> - - I've tried with the "ati" and "radeon" driver on XF86Config, UseFBDev is
> true.. can this be a matter of old XFree version?

Could be, check in the server log that radeon_drv.o is picked up from
the right place.

> The keyboard map isn't exactly alike the gravings in the keyboard.. like.. the
> left key of "z" is supposed to be: `, or ~ if shift is pressed.. however.. the
> output is "<" and ">" for the shift.
> also.. the key right above Esc doesn't correspond to the graving in the keyboard.
> I would like to correct this.. is this known..? I've seen stuph like..copying
> some i386 keymaps to the /usr/share/keymaps/mac and use them.. didn't tried
> out.. (silly fear of staying with a messed up keymap has it happened to me too
> much times before I got it right).
> ~ What is the correct fix for this?

To fix the relevant files in /etc/X11/xkb or create new ones if

> One other thing, i've read in some help guide that the dma sound support works
> but is very cpu intensive and that alsa would be better,

There is a difference (e.g. it makes all the difference between smooth
sound and stuttering in amoeba), but I'm not sure it's CPU usage, maybe
ALSA just returns earlier from some ioctls or similar.

> anyone has sound working with alsa?

Yes, I build the modules with make-kpkg from alsa-source and have

alias		snd-card-0		snd-powermac
alias		sound-slot-0		snd-pcm-oss
alias		sound-service-0-0	snd-mixer-oss
post-install	snd-pcm			modprobe snd-card-0

in /etc/modutils/sound .

Earthling Michel Dänzer (MrCooper)/ Debian GNU/Linux (powerpc) developer
XFree86 and DRI project member   /  CS student, Free Software enthusiast

Reply to: