[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

About the latest Ibook, problems...

Hash: SHA1

I have a ibook with the following specs:
ATI Radeon 7500 Mobility (M7 it seems to be the codename)
gmac ethernet card
us keyboard..

I've seen references to ibook2 and ibook3 .. after all is this a ibook2 or a
ibook3 ?
(It would be nice to clear this so that pages on the net concerning the right
model are easily to spot.. and since I'm going to do such a web page when I get
things working).

I have problems with the X .. can't get it working .. i'm using ben's kernel,
I have 1024x768 on the console, radeonfb it seems.. and i have a radeon module
wich I believe is the DRI driver right?

I've seen some web pages with XF86Configs but it gives me allways a working
mouse, with a foreground somewhat broken.. strange colors, mouse button is a
square, ..it's pretty unusable.. the mouse seems to respond to the trackpad..
but that's it, can't go to the console.. and can't to squat in X.. i've tried
killing X from ssh.... but it stays the same.. with the exeption of the mouse
wich stops responding.. and still.. I can't get out of it.. basically..
Everytime I try to run X I get stuck, and the only way out is to reboot, or take
the batery off.
- - Should I have the radeon module running before running startx ?
- - I've tried with the "ati" and "radeon" driver on XF86Config, UseFBDev is
true.. can this be a matter of old XFree version?

The keyboard map isn't exactly alike the gravings in the keyboard.. like.. the
left key of "z" is supposed to be: `, or ~ if shift is pressed.. however.. the
output is "<" and ">" for the shift.
also.. the key right above Esc doesn't correspond to the graving in the keyboard.
I would like to correct this.. is this known..? I've seen stuph like..copying
some i386 keymaps to the /usr/share/keymaps/mac and use them.. didn't tried
out.. (silly fear of staying with a messed up keymap has it happened to me too
much times before I got it right).
~ What is the correct fix for this?

Also.. the Airport, I haven't tryid much with it since I just got it
yesterday..but modprobe airport doesn't do the job! :-p
Anyone could point me to some web pages.. or guides for setting this one?

One other thing, i've read in some help guide that the dma sound support works
but is very cpu intensive and that alsa would be better, anyone has sound
working with alsa?

Thanks in advance!
Miguel Sousa Filipe
Version: GnuPG v1.2.1 (GNU/Linux)
Comment: Using GnuPG with Mozilla - http://enigmail.mozdev.org


Reply to: