[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Re: Ti PBG4, can't get PCMCIA working

Benjamin Herrenschmidt writes:
 > >
 > >According to benh on this list, a fix from the paulus tree was lost in
 > >2.4.16-ben0 and PCMCIA is broken temporarily.
 > >
 > >> Note: the date is always one month in future after a restart:-( --
 > >> since the new kernel 2.4.16 or the last unstable update, I do not know
 > >> which was the cause, but this is a different topic.
 > >
 > >This is the one that's really pissing me off.  Anyone know a quick fix?
 > The fix for both is to update to 2.4.17pre2 in my tree (and avoid
 > devfs which appear to be a cause for various random crashes in 2.4.17-preX).
 > Ben.
I got the 2.4.17-pre2-ben0 running, but still the same problem with
Always this in messages:

While bootup:
Can't get bus-range for /pci@f2000000/cardbus@1a

And then:
cs: memory probe 0x90000000-0x90ffffff: excluding 0x90000000-0x90ffffff
cs: unable to map card memory!

Here are the complete messages, bootup and card insert at end:

Attachment: messages
Description: Binary data

Here is the kernel .config I use, I did not use devfs this time:

Attachment: .config
Description: Binary data

I tried the same /etc/pcmcia/config.opts and variants than before:

Attachment: config.opts
Description: Binary data

My lspci:

Attachment: lspci
Description: Binary data

What should I try next?


Reply to: