[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Re: I'm one step away from Airport

Thank you, jwb.

> > # ifdown eth0
> This likely erased all your useful routes.  Check /sbin/route.

Yep, sure did: good to know.  But what can I do?  I tried
route add -net netmask dev eth1
(based on the router and netmask from a Mac OS Mac that uses the UFO)
but it told me the netmask didn't match the router.

> also I hope you know about Apples helpful (*cough* ahem) munging of the
> WEP key.  If you type hex into the Airport "password", you need to
> translate that to get *actual* hex.  To stay sane, precede the WEP key
> with a dollar sign when configuring the Airport base station.

The Yellow Dog page I mentioned
(http://www.yellowdoglinux.com/support/solutions/airport22.shtml) says
that the "enc" argument to iwconfig can be found by getting the
"Network Equivalent Password" from the base station from Mac OS.
That's what I'm entering.  The base station itself is configured with
a string password; so I've also tried doing 
iwconfig eth1 enc s:thestringpassword 
which the iwconfig manpage said should work, and
that way I get a much longer hex key, padded on its end with
0000-0000's, but still no success.


Reply to: