[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Re: XFree86 update question

Ethan Benson wrote:

On Mon, Sep 10, 2001 at 09:27:10AM -0400, Russell Hires wrote:

Hello everyone, I did my normal apt-get update && apt-get dist-upgrade for woody last night, and when XFree86 [server] | [common] | [whatever] replaces the version that was there before, it completely replaces my keymap with something else. In order to fix this problem, I have reboot the computer, rather than just restart X. I was particularly frustrated last night as I was working with zope, and I lost all ability to do anything until I rebooted. Thank goodness my mouse still worked :-) Besides that, I get asked a few questions about new settings or staying with defaults and I can't even say what I want to do since the keys are all messed up...

Is there something that can be done about that? What causes that, anyway, user error on my part? ;-)
I had this same problem, and still can't figure out an answer to it. The breakage occurred between 4.0.3 and 4.1.0 (which may have just made it into testing?), and I upgraded kernel-image-2.2.19-pmac at the same time.

Fortunately, I have a Dvorak ~/.Xmodmap, which gives me most of the keys I need (though I only mapped alphanumeric keys, space and CR, so shift, ctrl, function keys, cursor, etc. are still broken, and it's not really usable), and survived the transition intact. So it appears that the default map has broken on upgrade, but my personal map still works fine. I tried both "macintosh" and "pc101" in dpkg-reconfigure xserver-xfree86, both of which should give the correct mappings for the new input layer (which I've been using since it first arrived in kernel-image-2.2.18pre21-pmac), right?

Second problem: using gdm and gnome-session, the mouse stops working after the first logout, that is, the mouse is frozen at the second gdm login screen. I observed this behavior also on an i386 system freshly installed with X 4.1.0 three weeks ago (but not on previously-installed continuously-upgraded systems), and switched to /dev/gpmdata, which solved it for some time, then it broke again, so I removed gpm. Unfortunately, there is no /dev/gpmdata on PPC, and with the X keymap broken I kinda "need" gpm to work at the console, so I haven't tried removing it.

switch the kernel to use linux keycodes.

Done that (long since).

BTW, I hadn't reported this yet since I haven't had time to look into details and assumed I must be doing something wrong. Thanks Russell for the post, now I know I'm not the only one! :-)


-Adam P.

GPG fingerprint: D54D 1AEE B11C CE9B A02B  C5DD 526F 01E8 564E E4B6

Welcome to the best software in the world today cafe! <http://lyre.mit.edu/%7Epowell/The_Best_Stuff_In_The_World_Today_Cafe.ogg>

Reply to: