[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Re: XFree4 on Pismo - kernel 2.4



Hi everybody,

First of all: thanks for your support. I'm writing this email out of my 
beloved kmail under xfree4 - i finally got it runninng at around 3 a.m.

I followed somebody's advice (i don't remember who it was) and browsed the 
mailing list archive. I was almost ready to give up when I found a posting 
with an XF86Config for a pismo - it worked right away, even with my kernel 
2.2.18pre21. You can find the message at 
http://lists.debian.org/debian-powerpc-0102/msg00444.html

Then I tried to compile kernel 2.4. I rsync'd with benh's tree at 
penguinppc.org like Jason told me to do. I also took his config, but made a 
few changes to it, i.e. filesystems. So they shoudn't really matter. Now, the 
kernel compiled fine, but when it came to linking everything together, it 
complained about missing functions in module kernel.o.
Then I got a new kernel tree and rsync'd with bitkeeper's tree at 
bitkeeper.fsmlabs.com. I took the exact same configuration from before and 
the kernel compiled, linked and bootet fine. It even does some sound. It is 
just noise at the moment, but maybe somebody can give me a hint there.
Then I just made one more modification to my 2.4 kernel because wvdial 
woudn't find the internal modem. I figured that I hadn't compiled serial 
support, so I added it, recompiled, rebooted - still no modem.
It works fine under 2.2.18pre21 - the one that comes with potato. So I'm 
still using 2.2.18pre21 'cause I need internet :-)

I'd appreciate some hints. Thanks a lot already,

Philipp



-- 
    Philipp von Weitershausen
[ *pronounce: "fun Viters-houzen" ]

Web http://www.philikon.de/
Home +49 330 569 4763
Cell +49 175 632 2022



Reply to: