[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Re: XFree4 on Pismo - kernel 2.4

>Then I tried to compile kernel 2.4. I rsync'd with benh's tree at 
>penguinppc.org like Jason told me to do. I also took his config, but made a 
>few changes to it, i.e. filesystems. So they shoudn't really matter.
Now, the 
>kernel compiled fine, but when it came to linking everything together, it 
>complained about missing functions in module kernel.o.
>Then I got a new kernel tree and rsync'd with bitkeeper's tree at 
>bitkeeper.fsmlabs.com. I took the exact same configuration from before and 
>the kernel compiled, linked and bootet fine. It even does some sound. It is 
>just noise at the moment, but maybe somebody can give me a hint there.
>Then I just made one more modification to my 2.4 kernel because wvdial 
>woudn't find the internal modem. I figured that I hadn't compiled serial 
>support, so I added it, recompiled, rebooted - still no modem.
>It works fine under 2.2.18pre21 - the one that comes with potato. So I'm 
>still using 2.2.18pre21 'cause I need internet :-)
>I'd appreciate some hints. Thanks a lot already,

Well, if you don't tell me which the errors are, I'll have difficulties
fixing them :)

You should resync again. My kernel is a pretty quickly moving target


Reply to: