[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Re: Ti PB -- nervous breakdown

>The First two days I need to discover that yaboot 1.1.1 does not work
>with the TiPB and to find a typo in my bootscript. So I copied the
>yaboot from the LinuxPPC 2000 Q4-CD.

Can you tell me what happend with yaboot 1.1.1 ? It should work.

>I tried to boot with a selfcompiled kernel that I use on my Pismo. And
>tried to install debian. What I did not know, kernel 2.4.2 has problems
>with the loop-device. So installing debian with this kernel was not possible.
>Ran in some other problems so I decided to install LinuxPPC Q4.
>Cause I have mol running on my pismo, I also run netatalk over ethertap
>to share file from both worlds.
>After I had LinuxPPC up and running on my TiPB i copied the kernel with
>modules from the pismo.
>Copied some config-files and the mol-directory (it is a selfcompiled mol-
>Everything went smooth but my ethernet was very slow!! My Pismo told me
>it is running full_duplex at 100MBit/s but the TiPB told me it is
>running half_duplex at 10MBit/s only. So to copy files from one
>PowerBook to another was no fun.
>But both PowerBooks run the same kernel with the same modules.

The Ethernet PHY is, I guess, different and not yet properly supported. Can
you tell me what the ethernet driver says during boot about the type of PHY ?

>After that I tried to run mol with netatalk-1.5. Mol starts but only
>displays video when I boot with video=aty128, if I boot with
>video=ofonly mol can not cope with this video-mode.
>But it is getting worser, after sometime I got kernel PANICs
>"segmentation violation!"

You get that with MOL exlicitely or also in normal usage ? If it happens
can you send me the panic infos along with the System.map from that kernel ?

>Switched off every daemon I could find like autofs, nfs, etc. Do not
>know if this helps.
>And another problem: I can not connect within mol to my netatalk-server.
>When I try to login, I´ve been asked about my login and password, I get
>the window where I can select the share I want to mount, but after
>double-clicking on a share I got "File-Server disconneted..." or
>So after three days, it looks like this
>1. Ethernet has problems to detect the right speed!
>2. Some mistyries PANICs and crashes with a kernel that runs smooth on a

I see no reason for those PANICs and crashes since that machine is basically a
Pismo with a wider screen, a G4, and a different ethernet PHY. The
ethernet problem
is probably normal. The others are definitely not.

>And some application problems:
>1. Can not connect to netatalk 1.5 with mol
>2. Can not run mol in 1152x768

What mode do you get with aty128fb ? I didn't know the display could adjust
to different modes, that's interesting, since AFAIK, we don't program the
flat panel registers to do scaling in aty128fb.
In any way, using aty128fb will get you better results than offb. I think
Olad Hering (olh@suse.de) have some patches for the video mode of this
machine to be supported by aty128fb. The sandard modedb may have it too.

>Please help me to get linux on my TiPB to work as smooth as on my pismo.
>	Christoph
>BTW. I can not afford two PowerBooks, the pismo has to be sold as soone

Reply to: