[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Re: modem not working

I'm running debian potato with kernel 2.2.18 and pppd 2.2.11 on a PowerMac 7500
with a SupraExpress 56k. I had a problem with the /dev/ttyS0 device that
I was using for my modem.  It would dial up but it just never could establish
a pppd connection.  Finally tried the old /dev/cua0 and now it works. I don't really
understand why though. I think it is somehow related to the modem and the mac
8-pin serial port.

Using /dev/cua0 could help, but then again it might not be supported in kernel
2.4.1.  If who need to know how to create /dev/cua0, let me know and I will
tell you how.

Hope this helps somewhat.

On Sun, Feb 11, 2001 at 04:56:49PM +0100, Sebastiaan wrote:
> Hi,
> I am new to Debian on PowerMac, so I hope my question will be a piece of
> cake for you.
> I have a powermac 7300, debian potato, fresh compiled kernel 2.4.1 and a
> supraexpres 33.6 modem.
> The problem: I can not connect the internet. I can call my ISP with
> minicom and everything seems to be ok, but when calling in with pon or
> wvdial, pppd stops. It seems from the logfiles that the problem is this:
> Serial connection established.
> ioctl(PPPIOCGFLAGS): invalid argument
> tcsetattr: Invalid argument
> Exit.
> I do not know if this is modem related, kernel or architecture (ppc). It
> worked under YDL (Redhat for PPC) and 2.2.12. I compiled ppp as a module
> (including the ppp_generic, ppp_deflate, etc).
> I have no problems with 2.4.1 on my i386 machine.
> What is wrong?
> Thanks in advance,
> Sebastiaan
> --  
> To UNSUBSCRIBE, email to debian-powerpc-request@lists.debian.org
> with a subject of "unsubscribe". Trouble? Contact listmaster@lists.debian.org

Reply to: