[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Re: LS-120 drive

On Sun, Feb 04, 2001 at 09:59:54PM +0100, Michael Schmitz wrote:
> > > I've applied the patch to usb-storage.c and compiled and inserted it, but I
> > > seem to be having trouble with scsi emulation still.  When I try 'mount -t
> > > vfat /dev/sda /mnt' I get:
> >
> > usb mass storage does not work under 2.2 kernels AFAIK.  i tried it
> > for quite awhile and finally gave up and upgraded to 2.4.  (on an
> > intel box)  mass storage works quite well under 2.4.
> Yes it does. 2.2.18 vanilla does just fine for me. linux-pmac-stable from
> a while back (pre18) compiled on PPC or Intel also works fine. For
> sufficiently relaxed definition of 'fine' on Intel (horrible crashes of
> the USB driver after a bus hang) if you absolutely insist on torturing the
> USB device by dumping one huge 200MB file to the device, but just fine
> most of the time. And just fine on my Lombard all of the time. That's with
> a 250MB Zip drive on the bus and nothing else, and building the uhci or
> usb-uhci drivers as modules instead of builtin seemed to help a lot with
> stablity for some reason.

interesting, in my case the device is a digital camera that shows up
as a mass storage device.  under 2.2 kernels the kernel recognizes the
device but never allocates a node to it, under 2.4 it works the same
except the device is allocated /dev/sda.  i messed with it for a very
long time until i found references saying mass storage relied on the
2.4 scsi layer and didn't work under 2.2 so i gave up and upgraded to
2.4 which worked immediately.

> I have to insert the usb-storage module manually though. Upon loading that
> module, it will intialize a SCSI host probe to find the USB bus as new
> host adapter, and probe for devices on that host adapter's bus. Watch for
> errors in the log output from the modprobe usb-storage command.

maybe thats it, i compiled it into the kernel (which works fine on
2.4) i did get the messages from the kernel saying it detected the
device when i plugged it in, it just neglected to allocate a node each
and every time.  

Ethan Benson

Attachment: pgp70c0LvLmpT.pgp
Description: PGP signature

Reply to: