[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Re: yaboot on iMac/DV and iBook firewire

Quoting Ethan Benson <erbenson@alaska.net>:

> On Mon, Oct 16, 2000 at 12:45:13PM +0200, Hadess wrote:
> > Hi,
> > 
> > I updated yaboot to the potato-proposed-updates and I still have the
> same
> > problems:
> > yaboot console not showing up (even with the install-console keyword)
> does it work blind?  or does it not work at all?

If I just run ybin, and show up the Open Firmware, on "boot" it says:
Parsing <CHRP-BOOT>

DEFAULT CACHE!, code=70 at %SRR0: ff80c1c0 %SRR!: 0000b030

> > yaboot choice not showing up on the OF OS selector (option key)
> something is very very wrong here.

I reckon it is because the CHRP script gives an error, and is therefore not
considered bootable.

> > yaboot *not* being the default OS after a OF reset, and simply using
> "boot" (on
> > both machines, the Apple_Bootstrap partition is before the MacOS one,
> if one
> > exists...)
> have you FULLY reset your OpenFirmware?

Alt-Apple-P-R on the chime, hold 'till you listen to the second chime...
> > Ethan, I'm gonna update to the woody version, check it, and if
> necessary to the
> > latest unpackaged version.

I have not yet done so.

> i need to see:
> your complete /etc/yaboot.conf
> output of ybin -V
> output of `nvsetenv'  (using new powerpc-utils package)

I don't know if nvsetenv is new enough... It prints some weird stuff at the
> output of mac-fdisk -l /dev/hda
> if all that is correct we may be looking at a new incompatible OF...
> i certianly hope not, does anyone else have one of these machines?
> and if so are you having these problems?

I really hope it is not some new changes they've made only to this machine, I
already can't get the sound, and dri to work... (yeah, 2.4.0-test9 with sound
compiled in oopses, and module is broken :/)


Attachment: yaboot.conf
Description: Binary data

Reply to: