[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Re: X Trouble

Edwin Rudolph <stu12915@westga.edu> writes:

> I just installed potato on my PowerBook and am having some trouble with
> getting the X server to work right.  I first tried to fire up X with the
> default FBDev server, and that didn't work at all.  The only way I could
> get X going was to use the Xpmac server from LinuxPPC.  Moreover, if I
> left the video device box unchecked in BootX, I get 8 bit mode, if I check
> it, I can get 32 bit mode.  

Have you tried the relevant Xpmac options?

> Another thing is the mouse button emulation--doesn't work at all.  

It should work on (left) option 2/3 (not option F2/F3). I had a
problem using different keys. Though I had mouse button emulation on
the consoles via BootX arguments and using gpm, on F9/F10 (103,108), the same
buttons didn't work with X. I solved this using xev (apt-get install
xcontrib); the X-keycodes are different from the console codes here
(F9/F10 is 109,117). 

> Even
> stranger is that sometimes it seems like the buttons are being pressed
> "magically"--as if the computer thought a button was being held down when
> it wasn't.  

A friend of mine who was new to PBs had this with MacOS. It turned out
he sometimes touched the trackpad with his palm, which was interpreted
as a single klick or made the mouse jump around.

>Other times, the mouse button doesn't do anything--nothing
> will happen when I click the button. (All of this is of course w/Xpmac).

May be window manager related. Sawmill is sometimes kinda sluggish;
flwm is not.

> BTW, this is (I think) the Wallstreet PB, Mach64 card.

FYI, PB 3400

> Any ideas would be appreciated.
> Thanks :)
> --
> Edwin Rudolph
> stu12915@westga.edu

Good luck

Reply to: