[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Re: Bug #60469: reported problem on PowerPC with PostgreSQL

On Thu, Mar 16, 2000 at 10:05:58PM +0100, Robert Ramiega wrote:
> On Thu, Mar 16, 2000 at 06:19:59PM +0000, Oliver Elphick wrote:
> > Georg Bauer <gb@hugo.westfalen.de> reported the following bug, which I
> > cannot reproduce on Intel architecture:
> [snip]
> > 
> > Has any other PowerPC user experienced this, please?
>  I guess it's all caused by the optimisation turned on in Debian packages
> (it's the same problem i reported lately in a private mail). 
>  AFAIR this problem is caused by too good optimisation in GCC on PowerPC (at
> least i think that one of PgSQL developers said something like that). Please
> just take care that in each source package release PoerPC uses -O0 instead of
> -O2 and all will be fine (6.5.3-14 source debs are ok, i've recompiled them
> yesterday and had no problem so far)

Please!  That's not an adequate solution... I know it requires a little
more work, but people need to sit down and figure out the problems with
gcc, not just ignore them. -O0 is a real penalty.


/--------------------------------\  /--------------------------------\
|       Daniel Jacobowitz        |__|        SCS Class of 2002       |
|   Debian GNU/Linux Developer    __    Carnegie Mellon University   |
|         dan@debian.org         |  |       dmj+@andrew.cmu.edu      |
\--------------------------------/  \--------------------------------/

Reply to: