[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Re: Sockoban

On 16-Mar-00, you wrote:

> --- Björn Johansson <amigafreak@home.se> wrote:
>> >> I have been using Debian(Slink) for a couple of days now, it's really,
>> >> really buggy :(.
>>> I didn't know/think slink works on powerpc at all?
>> Well, It don't. It's using my slow 040.
> Well, then you should rather post to debian-m68k@lists.debian.org I
> guess...
>>> You need a special kernel (the latest is 2.2.10) for APUS.
>> Yes I know. But then I haveto use the potato version, and since it's
>> still is in BETA-stage I thought it would be better to use a stable
>> version. That's why I chose Slink.
> potato is currently in 'frozen' state, there is no 'BETA' state in Debian.
> What ware you afraid of WRT stability? I've been using potato for about a
> year and haven't had major problems with it, can't remember any real
> problem in the last few months.

Afraid of? Well, let's just say I got some bad experience from another
operating system. I lost 3GB of data. What happened was that one of
my partitions became unreadable and it didn't have anything to do with
the hardware. So I'm much more careful nowadays. But anyway,
I'm convinced ;).

>> APUS 2.2.10, exactly what is the name of the file?
>> I *think* I already have it, hmm..
> ftp://sunsite.auc.dk/pub/os/linux/apus/2.2.x/vmapus-2000.03.10.gz
> You also need
> ftp://sunsite.auc.dk/pub/os/linux/apus/boothack/bh000311.lha

It doesn't seem to work. I have tried these:

bootstrap --apus -d -k vmapus-2000.03.10 root=dev/ram ip=off
bootstrap --apus -d -k linux -r root.bin root=dev/ram video=pal ip=off
bootstrap --apus -k linux -r ramdisk.image.gz root=dev/ram ip=off

I have included a bootlog. After the depacking of the kernel image, the
screen goes gray(just like it did with "Slink"), but the problem is that it
totally freezes. I have waited, perhaps 10 minutes. But, still no
progress :(. I have been reading a lot of Linux-docs recently, and their
example was to use the name: vmlinux as kernel, but since that's not the
name of the file I downloaded, I didn't use that. It was also stated that
sometimes you haveto add a certain parameter to make the kernel work, but
haven't found one yet...

>> When it comes to the "Slink" version, is it possible for me to get a
>> better kernel than: 2.0.36 somewhere? (for the m68k of course)
> ftp://sunsite.auc.dk/pub/os/linux/680x0/v2.2/linux-2.2.10.tar.gz
> or
> ftp://sunsite.auc.dk/pub/os/linux/680x0/v2.3/linux-2.3.47.tar.gz
> (but as you're concerned about stability... :)
> You'll have to build the kernel yourself.
> Maybe you could also take a kernel-package from potato, don't know about
> the dependencies.
>> It's not possible to use the APUS-kernel with the Slink distribution,
>> right? Maybe a stupid question but I haveto know ;).
> You mean with the one you have? No. PPC and m68k aren't binary compatible.
> Michel
> =====
> "Software is like sex; it's better when it's free"
> -- Linus Torvalds
> "If you continue running Windows, your system may become unstable."
> -- Windows 95 BSOD
> __________________________________________________
> Do You Yahoo!?
> Talk to your friends online with Yahoo! Messenger.
> http://im.yahoo.com
MVH  Björn "Bear" Johansson
Linux/m68k Amiga Bootstrap version 5.5
Copyright 1993,1994 by Hamish Macdonald and Greg Harp

Amiga model identification:
    Resource `draco.resource': not present
    Chipset: AGA
    Module `A1000 Bonus': not present
    Module `A4000 bonus': 0x00f9e660
    Module `NCR scsi.device': not present

Type a key to continue...

Amiga 4000 CPU: 68040 with internal FPU, AGA chipset

APUS: No BPPC+ SCSI interface detected.
APUS: No PCI Bridge detected.
Command line is 'root=/dev/ram ip=off'
Vertical Blank Frequency: 50Hz
Power Supply Frequency: 50Hz
EClock Frequency: 709379Hz

Found 1 AutoConfig Device
Device 0: addr = 0x00f01060

Found 1 Block of Memory
Block 0: 0x08000000 to 0x0bf80000 (65024K)
2048K of CHIP memory

The kernel will be located at 0x08000000
Kernel is compressed
Uncompressing kernel image ...........................................................done

Loading ELF Linux/m68k kernel...
RAM disk at 0x08ed9e2c, size is 851K

Kernel segment 0 at 0x08000000, size 1779356
Boot info        at 0x081b269c

Kernel entry is 0xc0000000
ramdisk dest top is 0x0bf80000
ramdisk lower limit is 0x08ed9e2c
ramdisk src top is 0x08faebe7

Type a key to continue the Linux/m68k boot...

Reply to: