Re: Perl vs Apache -- dpkg loses
I'll try to be a little clearer.
Robert Ramiega wrote:
> On Tue, Aug 10, 1999 at 07:10:56PM -0600, Jeremiah Merkl wrote:
> > Now, I checked the bug list, and it says that the dependency problem for
> > apache-common on "perl" has been fixed, with apache-common_1.3.6-14.
> > Message date was July 12th.
> What stops You from using apache_1.3.6-13 ?
> And if You are so eager than just download debian sources and make the package
> by yourself (it's not that hard =o)))
Nothing stops me from using 1.3.6-13. Matter of fact, that's what I'm
using right now. I did a force-depends with dpkg on the command line,
and it works just fine. The problem with it shows up when I try to use
apt/dselect to update to the current stuff in unstable -- apache-common
relies on "perl" which relies on "perl 5.004", which breaks libcgi-perl
and libwww-perl which rely on "perl5", which I need more at this point
and time. In other words, I can't have one thing I need without tossing
the other. <sigh> So, I forced the two together, and just don't get any
other bugfixes in the meantime.
> > So is the autobuilder just not doing its job? Or are there other
> > concerns why it hasn't been put into our unstable distribution?
> It might have some troubles building this package automatically (yesterday
> I compiled postgresql_6.5.1-5 and it failed to build all debs because of some
> pgtksh which should be build but wasn't <<I'll mail maintainer about that in
> a minute>>)
I was just hoping that someone who knew for sure would be able to reply.
I'm assuming if the autobuilder fails to build a package, SOMEone gets
notified. Then the question becomes, who does anything get done about
> > installed anyways. I could have gone with Perl 5.004, except libcgi-perl
> > depends on libwww-perl which depends on perl 5.005....wonderful mess we
> > have here.
> yeah! perl is a mess for now... oh! well... =o))
you're telling me. :) But, the bugs are getting fixed, slowly but
> > I actually haven't been able to upgrade anything (unless I do it by
> > hand, I guess) because dpkg just flops over dead stating:
> just downgrade to apache_1.3.6-13 and all should be well
That was the problem...I couldn't if I wanted the package for
I could, of course, just grab the modules from CPAN, but then I have to
worry about things being put in the right place for standard Debian file
locations, and what version it is, etc. Quite frankly, Debian's
"unstable" enough right now, without me adding extra stuff all over the
> > Could this be considered a bug against apt?
> I don't think so. It is You who broke dependecies so You are responsible
> for all the mess =o)
Actually, I probably should have directed that comment to the line which
"E: Internal Error, problem resolver broke stuff",
which sounds to me like one of those error messages you throw in when
you don't know exactly what went wrong.