[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Perl vs Apache -- dpkg loses

Now, I checked the bug list, and it says that the dependency problem for
apache-common on "perl" has been fixed, with apache-common_1.3.6-14.
Message date was July 12th.

So is the autobuilder just not doing its job? Or are there other
concerns why it hasn't been put into our unstable distribution?

I needed apache for CGI testing, so I "forced" the issue, and got it
installed anyways. I could have gone with Perl 5.004, except libcgi-perl
depends on libwww-perl which depends on perl 5.005....wonderful mess we
have here.

I actually haven't been able to upgrade anything (unless I do it by
hand, I guess) because dpkg just flops over dead stating:


Reading Package Lists... Done
Building Dependency Tree... Done
Correcting dependencies... Done
Sorry, but the following packages have unmet dependencies:
  apache-common: Depends: perl but it is not installed
E: Unable to correct problems, you have held broken packages.
E: Internal Error, problem resolver broke stuff
Some errors occurred while unpacking. I'm going to configure the
packages that were installed. This may result in duplicate errors
or errors caused by missing dependencies. This is OK, only the errors
above this message are important. Please fix them and run [I]nstall
Press enter to continue.

installation script returned error exit status 100.
Press RETURN to continue.

Could this be considered a bug against apt?

-Jeremiah Merkl

Reply to: