[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Re: Testing: lablgtk seems broken and does not build



On Mon, Apr 15, 2002 at 01:48:37PM +0200, Claudio Sacerdoti Coen wrote:
>  Hi,
> 
>  I am using the testing distribution and after the last update of
>  liblablgtk-ocaml and co to 1.2.3-4 I get lots of GLIB errors when
>  running my examples (after re-compilation, of course).
>  [I am a bit worried about this: woody freeze is approaching too
>   quickly....]
> 
>  So I have tried to recompile the package from the sources, but the
>  building fails in this way:
> 
> ocamlmktop -I /usr/lib/ocaml/lablgl -o lablgtktop unix.cma str.cma lablgl.cma -I . lablgtk.cma lablgtkgl.cma lablgnome.cma lablglade.cma gtkInit.cmo -dllpath /usr/lib/ocaml/lablgtk -dllpath /usr/lib/ocaml/lablgl 
> Error on dynamically loaded library: /usr/lib/ocaml/lablgl/dlllablgl.so:
> undefined symbol: gluTessNormal
> 

You are having problems with lablgl, not lablgtk here, anfd the above error
message is related to you using glide-mesa, and not another one (i build with
the X version myself).

Apparently, the glide-mesa you are using is based on a too old version of GLU,
which does not contain the TessNormal function. I did add a conflict with
glide-mesa to solve this problem, maybe you tried to override it.

That said, it may not (or may) related to the other problem you encounter.
Please could you be a bit more specific about those, and maybe send me a test
program, as well as the versions of libgtk and libglib as well as mesa you are
using ?

Friendly,

Sven Luther


-- 
To UNSUBSCRIBE, email to debian-ocaml-maint-request@lists.debian.org
with a subject of "unsubscribe". Trouble? Contact listmaster@lists.debian.org



Reply to: